togath

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 94 total)
  • Author
    Posts
  • in reply to: [ solved ] Add program to startup #12011

    togath
    Participant

    Thanks Tom,

    found it out 15 minutes ago, that ‘enable’ was missing 😀
    Now CuBox-i is set to 100MBit ever startup.

    Great, thaks for your help

    in reply to: [ solved ] Add program to startup #12008

    togath
    Participant
    [Service]
    ExecStart=/usr/sbin/ethtool -s eth0 speed 100 duplex full

    Ok, Im closing in on the problem: sytemctl does not like to pass parametes to a programme.
    Therefore I tried to refer to a shell script instead of calling ethtool directly:

    [Service]
    ExecStart=/root/setEth0.sh

    Nevertheless execution of the shell script keeps failing.

    I will keep you updated….

    in reply to: [CuBox-i4] GUI update issues with 17.6 #12007

    togath
    Participant

    No ticker, it’s the plain image (snapshot) without additional plugins installed yet.

    CPU-usage is normal – about 20% one core. No unusual high temperature.

    Ok, I will let you know if I find out anything worth telling 🙂

    in reply to: [ solved ] Add program to startup #12004

    togath
    Participant
    root@geexbox:~# systemctl status ethtool.service
    ● ethtool.service - Set CuBox-i to 100 MBit due to USB-briding
       Loaded: loaded (/usr/lib/systemd/system/ethtool.service; disabled; vendor preset: enabled)
       Active: inactive (dead)
    

    Do I need to register ‘ethtool’ as a service?

    • This reply was modified 1 year, 9 months ago by  togath.
    in reply to: [ solved ] Add program to startup #11998

    togath
    Participant

    I want to run ‘ethtool’ during startup to limit the ‘eth0’ speed to 100MBit of Cubox-i.

    Exceuting the command “ethtool -s eth0 speed 100 duplex full” in the shell sets the speed appropriately.

    So I created a new file named ‘ethtool.service’ with that content:

    [Unit]
    Description=Set 'eth0' speed to 100MBit due to USB limitation
    After=kodi.service
    
    [Service]
    ExecStart=/usr/sbin/ethtool -s eth0 speed 100 duplex full
    
    [Install]
    WantedBy=default.target
    

    But the speed is not changed it always stays after startup at 1000MBit
    Tried to change ‘WantedBy’ to ‘network-online.service’ or ‘kodi.service’ didn’t change anything.

    • This reply was modified 1 year, 9 months ago by  togath.
    • This reply was modified 1 year, 9 months ago by  togath.
    in reply to: [CuBox-i4] Everything seems to be write-protected #11994

    togath
    Participant

    Hi Rudi,

    sorry for the late reply. Didn’t manage to test anything before my vacation.

    ‘fschk’ revealed a dirty bit on the boot-partition. Did not spent so much more time to figure out the reason due to a freh install of 17.6.

    Thanks for your support.

    in reply to: CEC not working on CuBox-i #11861

    togath
    Participant

    Hi Rudi,

    thanks for all the support in this topic. Guess than it’s probably my AVR swalloing certain commands :-/

    Maybe I can come up with an alternative wiring … we will see
    Or I just use my old Phillips tv remote for Cubox-i

    in reply to: CEC not working on CuBox-i #11846

    togath
    Participant

    If I can support in any way please let me know.

    One more thing to mention: On Cubox-i the basic CEC functionality always works. Options like “switch to source” or “use tv language” are always executed properly. Only the tv-remote-keys are not recoginised.

    in reply to: CEC not working on CuBox-i #11843

    togath
    Participant

    Sure 🙂

    Same procedure:
    – Swtiched on tv+avr then Cubox-i
    – Pressed some tv-remote keys no reaction
    – Deactivated & activated CEC input with Yatse
    -> tv-remote does not work
    – Navigated to shutdown-menue with Yatse
    — end of log —

    Tried then again with option “Switch source to this device on startup” activated again and after switching CEC off&on tv-remote works

    Here is the log:
    stripped
    log6

    in reply to: CEC not working on CuBox-i #11841

    togath
    Participant

    Indeed I was playing a bit with the options lately. But “Switch source to this device on startup” has no noticable effect. Probably it only works when the CEC connection can be established sucessfully.

    in reply to: CEC not working on CuBox-i #11838

    togath
    Participant

    A very keen approach would be to just run a script after stat-up which deactivates and then reactivates CEC. Not nice, but it would surely do the trick :-/

    in reply to: CEC not working on CuBox-i #11836

    togath
    Participant

    Hi Rudi,

    new kernel applied no noticable changes.
    Newest log:
    log5
    stripped

    – tv and avr powered-up first, 30s later Cubox-i
    – Pressed some tv-remote keys, no reaction
    – Navigated to CEC with yatse & disabled it <b>in<b> kodi
    – After pressing OK in CEC-menu, tv-remote works – even if CEC should be disabled by now
    – Navigated & restared Cubox-i with tv-remote

    – After restart (not in the log) CEC is not working – it’s disabled

    in reply to: CEC not working on CuBox-i #11826

    togath
    Participant

    Some more info about the Cubox-(i) issue:

    When starting/switching to HDMI/switching on TV and CEC doesn’t work it always helps to turn CEC off. Afterwards tv-remote works quite happily. Turing CEC back on again (without reboot in between) has no effect.

    in reply to: CEC not working on CuBox-i #11807

    togath
    Participant

    *) forgot to mention: first boot CEC worked!

    in reply to: CEC not working on CuBox-i #11805

    togath
    Participant

    Hi Rudi,

    found some minutes. Now I’ve got a RPI with 17.x

    – First boot configured:: resolution, CEC according to CuBox-i, logging.
    – Shutdown. Clear log.
    – Second boot: CEC doesn’t work. Re-init of “Viera link” from tv-menue. CEC comes to live after some seconds.

    log4
    Already stripped

    • This reply was modified 2 years, 4 months ago by  togath.
Viewing 15 posts - 1 through 15 (of 94 total)