[ solved ] Atheros AR2413/2414

Home Forums GeeXboX for PC [ solved ] Atheros AR2413/2414

Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  tomlohave 11 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11947

    Katandbri
    Participant

    Hi, first a huge thanks for the efforts because to my knowledge GeeXboX is the only Kodi 17 fork which supports i386 PCs.
    Second, I installed the latest snapshot on a usb and booted on my laptop. Boot went smooth as silk but as soon as I tried to connect to the WiFi I got no luck. The WiFi card is an Atheros AR2413/2414.
    I used both the network configuration addon and modifying the \etc\network file but no luck.
    ifconfig shows only an eth0 (with Mac address of the ethernet port) and a lo but no wlan0.
    ifconfig shows no wireless extensions.
    Tried to force change IFACE to wlan0 but still no go.
    The only thing I didn’t try (yet) is to force the wlan Mac on IFACE
    How can I solve this problem?
    Thanks in advance

    • This topic was modified 11 months, 2 weeks ago by  tomlohave.
    #11950

    Katandbri
    Participant

    tried it on my netbook with Atheros AR9285 and still no wlan0 when I issue ifconfig

    PS: I’m using the latest devel snapshot

    #11951

    tomlohave
    Keymaster

    hello,

    Can you post using pastebin the results of ‘dmesg’ and ‘lsmod’
    Maybe you need additional firmware for this.

    #11952

    Katandbri
    Participant

    hi,

    Here is the lsmod output Link
    and the dmesg output Link

    Note, the above output is for the AR9285.
    Thanks in advance

    #11954

    tomlohave
    Keymaster

    hum, a quick look shows that we do not enable ATH9K in kernel’s config …
    I will give it a try in the afternoon 😉

    #11955

    Katandbri
    Participant

    and probably the same problem for the AR2413/2414 (AR5005G) chipset which runs on the ATH5K driver. :s

    #11956

    tomlohave
    Keymaster

    Hi,

    Here is a kernel to test :
    connect remotely to your geexbox’s machine then do :
    opkg install --force-reinstall http://download.geexbox.org/tests/tom/i386/linux_4.4.67-2_i686.opk

    #11976

    Katandbri
    Participant

    Great!
    Both AR2413/2414 (AR5005G) and the AR9285 worked perfectly!
    Huge thanks Tom 🙂

    PS will be posting two other issues in separate posts.

    #11982

    tomlohave
    Keymaster

    ok, thanks

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.