A few thoughts for the 20181017 i386 x86 build

Home Forums GeeXboX for PC A few thoughts for the 20181017 i386 x86 build

This topic contains 1 reply, has 2 voices, and was last updated by  ontheground 7 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12544

    ontheground
    Participant

    Hello. I’m a new user of your system.
    I have a HP T5740 thin client with a 32bit Atom processor previously with Openelec on it. Their build is outdated (Kodi 14.2 in it) and they doesn’t offer any 32 bit build anymore, so I have been looking into alternatives.
    There comes your development release: http://download.geexbox.org/snapshots/geexbox-kodi-i386-generic/20181015/binaries.i386/
    Here I put some suggestions for newbies like me, I hope somedy can use it.
    I installed Geexbox on a flash drive, cloned it with Clonezilla and reinstalled it on another hard drive. After that, I repaired the Syslinux(Extlinux) bootloader on the HDD with a Linux live CD and made the boot a little faster with editing /boot/syslinux.cfg’s Timeout property.
    The system works fine, after you configure your automatically recognized network cards.
    In order to do so, exit Kodi, fastly type CTRL-ALT-F1(Kodi reloads itself, its a strange behavior), the you are in a terminal, the default user/pass is root/root. I have one wlan0(wifi) and one eth0(wired) card, I had to edit their config files with
    nano /etc/network and nano /etc/network2 CTRL-O for save, CTRL-X for exit the nano text editor, then type in the terminal the reboot command. It reboots, and now if everything went fine, you have netwoirk access. It’s strongly recommended to change the default root password, you can do that in terminal with the passwd command

    The system is usable now, but there are other problems with this developer release.

    One particular is that it has the opkg package manager in terminal, but you cannot install anything from the repository, because the /etc/opkg/opkg.conf config file is having a bad path to the repository, You can edit it with the nano, the correct one is:

    src snapshots http://download.geexbox.org/snapshots/geexbox-kodi-i386-generic/20181015/binaries.i386/packages
    dest root /
    option force_space

    Then you can opkg update and you can install Midnight Commander for example, with opkg install mc command.

    Another big issue is that you can only poweroff and reboot from terminal, Kodi’s power menu buttons are just rebooting the Kodi on my system, I think it is some bug.
    There is a solution for that. You need to add a Polkit policy file named something.pkla to the directory /etc/polkit-1/localauthority/50-local.d.
    The contents of that file:

    [Allow all users to shutdown and reboot]
    Identity=unix-user:*
    Action=org.freedesktop.login1.*;org.freedesktop.upower.*;org.freedesktop.consolekit.system.*
    ResultActive=yes
    ResultAny=yes
    ResultInactive=yes

    It is allowing any users to shutdown/reboot the machine without typing in the root password.
    The other half is the solution is the editing of the Kodi skin. The default is Estuary, so you need to edit the DialogButtonMenu.xml file of that skin with the command
    nano /usr/share/kodi/addons/skin.estuary/xml/DialogButtonMenu.xml

    You need to change the $LOCALIZE[13016] and the $LOCALIZE[13013] labelled items in the xml file to:

    
    					<item>
    						<label>$LOCALIZE[13016]</label>
    						<onclick>System.Exec("/usr/sbin/poweroff")</onclick>
    						<visible>System.CanPowerDown</visible>
    					
    					<item>
    						<label>$LOCALIZE[13013]</label>
    						<onclick>System.Exec("/usr/sbin/reboot")</onclick>
    						<visible>System.CanReboot</visible>
    					</item>
    

    Then you restart/shutdown your machine from terminal, and the next time the Kodi starts these buttons will work as they should.
    Maybe you can modify the Suspend and Hibernate commands too, to do what they should, I don’t know.
    The Quit command is still restarts the Kodi application, I haven’t find any fix yet, maybe needs a script, I don’t know.

    That’s it. I’m satisfied with this build, even if it is a development version it works fine for me. Thank you all for that.

    • This topic was modified 7 months, 3 weeks ago by  ontheground.
    • This topic was modified 7 months, 2 weeks ago by  Warped Rudi.
    #12547

    ontheground
    Participant

    Hello. I’m a new user of your system.
    I have a HP T5740 thin client with a 32bit Atom processor previously with Openelec on it. Their build is outdated (Kodi 14.2 in it) and they doesn’t offer any 32 bit build anymore, so I have been looking into alternatives.
    There comes your development release: http://download.geexbox.org/snapshots/geexbox-kodi-i386-generic/20181015/binaries.i386/
    Here I put some suggestions for newbies like me, I hope somedy can use it.
    I installed Geexbox on a flash drive, cloned it with Clonezilla and reinstalled it on another hard drive. After that, I repaired the Syslinux(Extlinux) bootloader on the HDD with a Linux live CD and made the boot a little faster with editing /boot/syslinux.cfg’s Timeout property.
    The system works fine, after you configure your automatically recognized network cards.
    In order to do so, exit Kodi, fastly type CTRL-ALT-F1(Kodi reloads itself, its a strange behavior), the you are in a terminal, the default user/pass is root/root. I have one wlan0(wifi) and one eth0(wired) card, I had to edit their config files with
    nano /etc/network and nano /etc/network2 CTRL-O for save, CTRL-X for exit the nano text editor, then type in the terminal the reboot command. It reboots, and now if everything went fine, you have netwoirk access. It’s strongly recommended to change the default root password, you can do that in terminal with the passwd command

    The system is usable now, but there are other problems with this developer release.

    One particular is that it has the opkg package manager in terminal, but you cannot install anything from the repository, because the /etc/opkg/opkg.conf config file is having a bad path to the repository, You can edit it with the nano, the correct one is:

    src snapshots http://download.geexbox.org/snapshots/geexbox-kodi-i386-generic/20181015/binaries.i386/packages
    dest root /
    option force_space

    Then you can opkg update and you can install Midnight Commander for example, with opkg install mc command.

    Another big issue is that you can only poweroff and reboot from terminal, Kodi’s power menu buttons are just rebooting the Kodi on my system, I think it is some bug.
    There is a solution for that. You need to add a Polkit policy file named something.pkla to the directory /etc/polkit-1/localauthority/50-local.d.
    The contents of that file:

    [Allow all users to shutdown and reboot]
    Identity=unix-user:*
    Action=org.freedesktop.login1.*;org.freedesktop.upower.*;org.freedesktop.consolekit.system.*
    ResultActive=yes
    ResultAny=yes
    ResultInactive=yes

    It is allowing any users to shutdown/reboot the machine without typing in the root password.
    The other half is the solution is the editing of the Kodi skin. The default is Estuary, so you need to edit the DialogButtonMenu.xml file of that skin with the command
    nano /usr/share/kodi_addons/skin.estuary/xml/DialogButtonMenu.xml

    You need to change the $LOCALIZE[13016] and the $LOCALIZE[13013] labelled items in the xml file to:

    
    					<item>
    						<label>$LOCALIZE[13016]</label>
    						<onclick>System.Exec("/usr/sbin/poweroff")</onclick>
    						<visible>System.CanPowerDown</visible>
    					
    					<item>
    						<label>$LOCALIZE[13013]</label>
    						<onclick>System.Exec("/usr/sbin/reboot")</onclick>
    						<visible>System.CanReboot</visible>
    					</item>
    

    Then you restart/shutdown your machine from terminal, and the next time the Kodi starts these buttons will work as they should.
    Maybe you can modify the Suspend and Hibernate commands too, to do what they should, I don’t know.
    The Quit command is still restarts the Kodi application, I haven’t find any fix yet, maybe needs a script, I don’t know.

    That’s it. I’m satisfied with this build, even if it is a development version it works fine for me. Thank you all for that

    #12549

    Warped Rudi
    Keymaster

    Thanks for the comments. We’ll see what we can do about it. I have to admit, that the Intel platforms did not get much attention during the last few years due to the advent of small ARM devices like Cubox or RaspberryPi…

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.