library update errors with scrapers

Home Forums GeeXboX on ARM SoCs library update errors with scrapers

This topic contains 7 replies, has 2 voices, and was last updated by  Peter 3 years, 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #10104

    Peter
    Participant

    Hi, i have some questions and i think its mostly Kodi/XBMC issue.

    i have some problems with the movie scrapers connection with the remote server:
    I have a exended library and somehow it can’t connect to the server when i hit the scan library button.
    it posp up something like: “no connection possible with remote server, do you want to continu to scan?”

    I tested some things:
    1: used Yatse button (reinstalled yatse) and used the in kodi: Left menu library scan. sometimes it works, most of the time it didn’t.
    2: changed from the movie database scraper to UMS. (well that did cleanup the hole librarydata and rebuild it from scratch ARGH.) But it did the trick for a wile. but still errors after a week.
    3: Did a fresh build and that give the same issue after updating and scraping the librarydata.
    4:now a days the scraper connects some times after a seconds time out. mostly it give the error no connection possible. (the movie are stored at a nass and i checked even when its idle or just streaming a videofile it gives a error. (internet connection is checked and correct
    5: manualy info => renew librarydata is working fine so themoviedb.org is connecting.

    could it be a problem caused by the large library? ive read something about to much query request.
    (is there a setting to adjust a delay time for connecting to UMS so it can build up a connection? i read somewhere that in openelec that solved the problem.)

    the last thing i can try is do a nightly build version of november 19 and see of this is solving my library issue.
    (ps is the optical spdiff issue solved in a other thread allready embedded in the nightly build?)

    And can someone tell me which kodi is implanted in geexbox november build?
    15 or still 13?

    #10105

    Peter
    Participant

    Cant edit so:
    1 it is still kodi 13.2
    2 also in this build is scraper problem not solved.(ive used xbmc back to restore)
    i will try later on a fully fresh installation.

    is it the server moviedb.org or the nass server at home connection who’s causes the problem?

    #10106

    Warped Rudi
    Keymaster

    There is no such thing as Kodi 13.2. There is Kodi 15.2 and XBMC 13.2. Currently we build both. But you can get the Kodi variant only when doing a fresh install from http://download.geexbox.org/snapshots/geexbox-kodi-imx6-cuboxi/ or install via ignition.

    #10107

    Peter
    Participant

    @Warped Rudi: thanks for the link.
    sorry, your right. They renamed XBMC to Kodi somewhere around XBMC 13.2.
    I was in the suggestion that it was the same now.

    And im happy to see (and respectfull because i can’t) that you and others are building/developing Geexbox to Kodi 15.2 and that SolidRun(forum/site) is coöperating to make this cubox-i/Geexbox forward moving succes
    Im realy appreciate all your efforts to get us users a nice home entertainment device!

    Sorry for the newbe/novice kind of behaviour, finding the right links or page’s is a bit difficult when you not in the loop. (or active in development circel.)

    And thanks for the other suggestion to install: http://solid-run.com/downloads/ignition.

    i think i will try that ignition-setup one to see how thats like. The other method im familiar with (so far possible) 🙂

    it seems simple to do. Is Ignition uses the snapshots from the same link as above? (so both ways end up with the same installation and appearance of Geexbox.) Or is Geexbox with the ignition installation somehow different in setup, apperance or installed addon’s?

    And do i need to be aware of some things when doing a fresh installation of Geexbox with kodi 15.2?
    like not use the xbmc-backup files from XMBC13.2 to fast setup of the usersettings or so?
    And just to be sure and for understanding: why build both versions? is kodi 15.2 not totaly stable yet in Geexbox? Or somehow not totaly usable for all addons wich are available for 13.2?

    #10109

    Warped Rudi
    Keymaster

    Is Ignition uses the snapshots from the same link as above?

    Yes. It queries http://download.geexbox.org/snapshots/ for download information.

    And do i need to be aware of some things when doing a fresh installation of Geexbox with kodi 15.2?
    like not use the xbmc-backup files from XMBC13.2 to fast setup of the usersettings or so?

    I don’t know. The fact that nobody has tried this is one of the reason why we don’t offer an upgrade path at the moment. Kodi uses different directory names (…/kodi/… vs. …/xbmc/…). So normally it would not use restored stuff from xbmc. However, in some cases it installs symlinks xbmc -> kodi, which allows Kodi to use for example addons that were designed for xbmc.

    why build both versions?

    As said before: we don’t have a proven upgrade path. The second is that until about a week ago the kodi branch contained a lot more changes (kernel, GPU drivers etc.) that we did not want to go directly into the ‘stable’ build. However, with the november versions the difference between the two images is really just Gotham 13.2 vs. Isengard 15.2, libCEC 2.x vs. libCEC 3.x and some naming stuff xbmc vs. Kodi. The xbmc images for platforms that have Kodi support will disappear eventually. We just have not decided when…

    #10110

    Peter
    Participant

    Ok thanks for the info.

    ive tryed Ignition, didn’t work, won’t write to SD with win32DI gifs a write error.
    And someone on tweakers emailed with SolidRun developer Rabeez who replyed that there are no more resources connected to Cubox-i and that he is developing something else. Ignition isn’t (probably) anymore updated by SolidRun.

    So i went for the normal way and did total clean install of Geexbox isengard 15.2, 17 nov build.
    And did/stil do a total rebuild of the userdata/library. (kept the old one (13.2) as a img backed up.)
    new install runs well so far.

    Do have a “can’t acces remote server” issue again after first library build up.
    I have the impression that when Storage server (nass) is a bit slow answering this message is popping up.
    And the big library has problems to connect properly.
    Is here a way to extend the waiting time to establish connection with the Nass?
    May handy to build in a option for optional setting delaytime libraryscan. (or is this a Kodi related problem?)

    Is there (will you be so kind to put) a announcement on this site when the new build of Geexbox with Isengard 15.2 including kernel, gpu drivers update you talking about etc. is stable and put on snapshots?
    So we (users) know when we can upgrade this safely?

    Thanks in advanced.
    (keep up the good work 🙂 )

    #10133

    Peter
    Participant

    Bump….

    sorry, ive still have that issue of can’t acces remote server and ive found no answer on the big web.
    except this: you need to add the following to your advancedsettings.xml:

    Code:
    <videoscanner>
    <ignoreerrors>true</ignoreerrors> <!– Set to true to silently ignore errors while scanning videos. This prevents the error dialogue box, so you don’t have to keep hitting “yes” to keep scanning.–>
    </videoscanner>”
    (This is a 2013 thread)

    Does this mean that the error is mostly a time out error caused by the scraper website?
    Can someone point me in the right direction to solve this problem?
    (i know it isn’t most likely a Geexbox issue more something in Kodi)

    again thanks in advance!

    #10134

    Peter
    Participant

    Update: ive bin struck by lighting! that fired up a bulb…;-)

    its the music video dbscraper wich gives the errors.
    just leave the music video’s folder out of library scanning:=> done!
    probably a failure of reignition of the file name….

    case closed!

    🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.