[ solved ] Work-arounds for audio & timezone

Home Forums GeeXboX for PC [ solved ] Work-arounds for audio & timezone

This topic contains 51 replies, has 3 voices, and was last updated by  tomlohave 7 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 52 total)
  • Author
    Posts
  • #1316

    billh
    Participant

    V2 on USB with HP D510C desktop & Radeon X1300 AGP.
    Here are hacks that worked for me:
    1. Audio was not setting up correctly at boot 99% of the time. Didn’t want to have to train my family to work the Mixer Add-on. Added a delay at the very beginning of the “/usr/lib/alsa-utils/alsa-mixer-setup” script. I used “sleep 60”. It worked consistently so I didn’t experiment with lower values.
    2. Timezone setup was not working. Problem solved by copying the entire /usr/share/zoneinfo folder from my linux box onto the usb at /usr/share.

    Now v2 is almost usable for me…I wish I can get my ATI Remote Wonders II to work! For that I might have to wait for 2.0.1.

    Thanks for all the hard work!

    #1318

    tomlohave
    Keymaster

    That’s already in tree and ready for 2.01
    for the sound issue, we suspect thet alsa-mixer-setup is launch too early (that seems confirmed with your fix)
    can you test this please to help us :
    1) remove your fix
    2) modify /lib/systemd/system/mixer.service like this :

    [Unit]
    Description=ALSA mixer configuration

    [Service]
    Type=oneshot
    EnvironmentFile=/etc/audio
    ExecStart=/usr/lib/alsa-utils/alsa-mixer-setup
    RemainAfterExit=yes
    After=sysinit.target <<<<<<< add this line [Install] WantedBy=multi-user.target Reboot Thanks for the report. for the remote , i can help you to install it (it needs 3 packages)

    #1329

    billh
    Participant

    Sorry to report that adding “After=sysinit.target” in the [Service] section of “mixer.service” did not work.

    I kind of went down this road before I stumbled on the hack to the alsa-mixer-setup script. For a fews days, I had it working when I explicitly added these 2 statements:
    ExecStart=amixer sset Master 75% unmute
    ExecStart=amixer sset PCM 75% unmute
    to the [Service] section of ‘xbmc.service’. I don’t know what I did a few days later that changed the booting process & broke this fix.

    Anyway, I experimented with the added delay in alsa-mixer-setup. It works when I use 2 secs or more; 1 sec would not work. Hope this sparks another idea for you.

    The HP D510C has a Pentium 4 @ 2.53GHz & audio “card” spec of “Intel 82801DB-ICH4 with AD1981A at IRQ 17”.

    As for the ATI Remote Wonder II, I’m interested in trying out your 3 packages. Please let me know where to get them & what I need to do.

    Thanks.

    #1331

    tomlohave
    Keymaster

    arf, bad news.

    For the remote :
    install this two packages
    http://download.geexbox.org/releases/extra/i386/eventlircd_42-1_i686.opk
    http://download.geexbox.org/releases/extra/i386/lirc_0.9.0-1_i686.opk
    and modify /lib/systemd/system/xbmc.service like this :
    ExecStart=/usr/lib/xbmc/xbmc.bin –standalone -fs -l /var/run/lirc/lircd

    #1334

    tomlohave
    Keymaster

    for the sound : (i cant test , no problem with sound), please try this :
    create a file in /lib/udev/rules.d called 40-alsa.rules , and add to this file :

    # /lib/udev/rules.d/40-alsa.rules
    # When a sound device is detected, restore the volume settings
    KERNEL==”controlC[0-9]*”, ACTION==”add”, RUN+=”/usr/lib/alsa-utils/alsa-mixer-setup”

    (remove your fix) Reboot and test.
    Please report
    Thanks

    #1343

    billh
    Participant

    No go on the audio fix..

    Here’s what’s in my /lib/udev/rules.d folder:
    total 61
    drwxr-xr-x 2 1000 1000 4096 .
    drwxr-xr-x 6 1000 1000 4096 ..
    -rw-rw-r– 1 root root 182 40-alsa.rules
    -rw-r–r– 1 1000 1000 764 42-qemu-usb.rules
    -rw-r–r– 1 1000 1000 219 50-firmware.rules
    -rw-r–r– 1 1000 1000 3058 50-udev-default.rules
    -rw-r–r– 1 1000 1000 584 60-cdrom_id.rules
    -rw-r–r– 1 1000 1000 649 60-persistent-alsa.rules
    -rw-r–r– 1 1000 1000 2464 60-persistent-input.rules
    -rw-r–r– 1 1000 1000 944 60-persistent-serial.rules
    -rw-r–r– 1 1000 1000 1423 60-persistent-storage-tape.rules
    -rw-r–r– 1 1000 1000 6085 60-persistent-storage.rules
    -rw-r–r– 1 1000 1000 785 60-persistent-v4l.rules
    -rw-r–r– 1 1000 1000 166 61-accelerometer.rules
    -rw-r–r– 1 1000 1000 462 75-cd-aliases-generator.rules
    -rw-r–r– 1 1000 1000 654 75-net-description.rules
    -rw-r–r– 1 1000 1000 4083 75-persistent-net-generator.rules
    -rw-r–r– 1 1000 1000 254 75-probe_mtd.rules
    -rw-r–r– 1 1000 1000 654 75-tty-description.rules
    -rw-r–r– 1 1000 1000 4311 78-sound-card.rules
    -rw-r–r– 1 1000 1000 657 80-drivers.rules
    -rw-r–r– 1 1000 1000 3063 95-keyboard-force-release.rules
    -rw-r–r– 1 1000 1000 10874 95-keymap.rules
    -rw-r–r– 1 1000 1000 155 95-udev-late.rules
    -rw-r–r– 1 1000 1000 2084 99-systemd.rules

    Here’s my 40-alsa.rules file content:
    # /lib/udev/rules.d/40-alsa.rules
    # When a sound device is detected, restore the volume settings
    KERNEL==”controlC[0-9]*”, ACTION==”add”, RUN+=”/usr/lib/alsa-utils/alsa-mixer-setup”

    As for the remote, eventlircd_42-1_i686.opk installed fine. However, lirc_0.9.0-1_i686.opk gave me the following error:
    Installing lirc (0.9.0-1) to root…
    Collected errors:
    * Satisfy_dependencies_for: Cannot satisfy the following dependencies for lirc:
    * libftdi *
    * opkg_install_cmd: Cannot install package lirc.

    Thanks.

    #1344

    tomlohave
    Keymaster
    #1353

    billh
    Participant

    Ok, installed the libftdi & lirc packages without any error; modified the command line option for the xbmc.bin statement in xbmc.service file; rebooted but no response to my ATI Remote Wonders II.

    Checked in /dev; I don’t see any lirc entries. This hardware setup works with v1.2.4. Is there anything else I need to set up for v2?

    Thanks.

    #1358

    tomlohave
    Keymaster

    The kernel does not contain the module uinput
    try with this package ( you may force the install 🙂 ) :
    http://download.geexbox.org/releases/extra/i386/linux_2.6.38.8-1_i686.opk

    #1366

    billh
    Participant

    Was able to install linux_2.6.38.8-1_i686.opk without forcing – no dependency complaints!

    Rebooted; saw 2 errors (red letters) fly by on the screen during boot:

    1. Starting Load Kernel Modules Failed, see ‘systemctl status systemd-modules-load.service’ for details.
    then,
    2. Starting LIRC initial setup failed, see ‘systemctl status lirc-setup.service’ fo…

    What now?

    Thanks.

    #1367

    tomlohave
    Keymaster

    i will upload an iso (not a release , an iso for test) for you please wait …
    There is too much difference between my developpement tree and this version.

    #1368

    billh
    Participant

    Don’t know if this helps… systemctl status for the 1st error gives:
    Process: 340 ExceStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILED)

    #1373

    tomlohave
    Keymaster
    #1384

    billh
    Participant

    Put iso r13329 on USB with 256M persistent…

    Booting… I see one error:
    Starting LIRC initial setup failed, see ‘systemctl status lirc-setup.service’ fo…
    (I didn’t see the other error with Load Kernel Modules this time.)

    However, it doesn’t finish booting… stops at “Starting Wi-Fi Security Services…”

    I can switch to vt2 though… (reports as r13277!)

    Thanks.

    #1385

    tomlohave
    Keymaster

    the r13277 is not a problem (i forgot to change version in my .config file)
    can you post dmesg results and what say
    systemctl status xbmc.service ?

Viewing 15 posts - 1 through 15 (of 52 total)

You must be logged in to reply to this topic.