USB Dongle fully working

Home Forums GeeXboX on ARM SoCs USB Dongle fully working

This topic contains 7 replies, has 3 voices, and was last updated by  cris 4 years, 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #4765


    Hi all,

    Someone  know a USB Wifi dongle fully working with GeexBox on Cubox?

    My only request is that it dosen’t be a realtek product : I have a lot of problems with theirs product…



    I managed to get a cheap USB dongle of dealextreme ( working after modifying the networking script (see the Geexbox thread on Solid-Run forum on how I did it). However this realtek chip was not stable on the Cubox, as soon as I tried to copy a movie (via ftp or samba), it went offline after 5 minutes transferring and it didn’t came back. So indeed perhaps avoid Realtek. Now I use a Philips Wifi to utp ethernet hardware receiver in the mean time without any issues. I am also interested to know which (cheap) wifi dongle has stable results.



    Thank you for your answare.

    The thread that you talk about is  one?



    yep on page 9 I posted the script and finally I just edited the networking.service  file to launch that one instead of the standard network config script (you could also disable the standard one and create a new service like in my post). I tried in the latest Geexbox 3.0 to use the standard way again (either by xbmc config screen and as 2nd option editing /etc/networking) but both configurations didn’t work out for me.



    Hi everybody!

    I’m new here and a newbie into Linux wolrd. But I’m trying to learn better every attempt I try on it!

    So I’ve bought a CuBox with 1GB ram and Linux version 3.5.7 (geexbox@SolidRun-PC) (gcc version 4.6.4 20121001 (prerelease) (Linaro GCC 4.6-2012.10).

    I’ve the same problems with usb dongle: no way out! I’ve an old usb dongle (Edimax 7315Ug with Atheros AR5523 inside) and with ndiswrapper I used it fine with Ubuntu 32bit x86: so why don’t use it with CuBox?

    I’ve tried searching something on the web but… nothing useful. My questions are:

    – is there any chance to build/make or similar into ARM geexbox from any source (code, debian, etc…); I mean the “usual” make/make install?

    – is there some module-assistent opk to install?

    I must admit the best would be an ARM ndiswrapper but till then I’m keep on trying and if  I could, I’d like to share my poor results with you.

    Thanks in advance



    For example I’ve found these packages from the Official wifi Linux drivers site:

    – compat-wireless-3.5.4-1.tar.bz2\compat-wireless-3.5.4-1\drivers\net\wireless\ath\ar5x (with the complete internal path);

    – compat-drivers-3.8-1-u.tar.gz\compat-drivers-3.8-1-u\drivers\net\wireless\ath\ar5523

    As reported from the site itself, they’re different due the different kernel linux.

    How they could be useful?



    Here my experience:
    – the Atheros chipset AR5523 on the Edimax 7315Ug (my first dongle and now my brother’s dongle) doesn’t work/recognized;
    – the Ralink RT2571WF on the D-Link G-122 (my brother’s old dongle) doesn’t work properly. I’ve seen the excact problem just posted from @jschaeke (the second post here);
    – the Realtek RTL8192C on the Atlantis micro usb dongle (my pc dongle) doesn’t work/recognized.

    Now I use on CuBox (before the problem with connman) a WUSB Linksys with a up-to-date Ralink chipset with no problem

    I hope may help



    Hi all!

    Is there a sw for geexbox (CuBox) like inSSIDer for PC?
    I mean I’d like to have a feedback about my signal strenght from wifi dongle: is it possible?
    Tnx in advance


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.