Problem with

Home Forums GeeXboX on ARM SoCs Problem with

This topic contains 4 replies, has 2 voices, and was last updated by  sebastian 1 year, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #10950


    Hi there,

    currenty I am running Geexbox on a Raspberry 3 without any big issues. Lately I tried to use an addon (Flix2Kodi) which should be able to work with NetFlix. When I try to run this addon I get an error message on Screen and in the logfile there is:

    11:29:52 T:1791484832   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                 - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                Error Type: <type 'exceptions.ImportError'>
                                                Error Contents: /usr/lib/python2.7/site-packages/Crypto/Cipher/ undefined symbol: rpl_malloc
                                                Traceback (most recent call last):
                                                  File "/root/.kodi/addons/", line 10, in <module>
                                                    from resources import general
                                                  File "/root/.kodi/addons/", line 7, in <module>
                                                    import add
                                                  File "/root/.kodi/addons/", line 10, in <module>
                                                    from resources import library
                                                  File "/root/.kodi/addons/", line 9, in <module>
                                                    import get
                                                  File "/root/.kodi/addons/", line 18, in <module>
                                                    from resources import connect, video_parser
                                                  File "/root/.kodi/addons/", line 15, in <module>
                                                    from resources import chrome_cookie
                                                  File "/root/.kodi/addons/", line 23, in <module>
                                                    from Crypto.Cipher import AES
                                                  File "/usr/lib/python2.7/site-packages/Crypto/Cipher/", line 50, in <module>
                                                ImportError: /usr/lib/python2.7/site-packages/Crypto/Cipher/ undefined symbol: rpl_malloc
                                                -->End of Python script error report<--

    I tried to reinstall PyCrypt but this does not work.

    I also tried to set an env as mentioned here: before reinstalling it.

    Any help is appreciated



    Warped Rudi

    Please try the *.opk file found here.
    Since these packages are pre-built, the solution mentioned in the blog must be applied on our side.

    P.S.: You are the first person reporting to use Geexbox on a RaspberryPi3. I wonder, if there are more 😉



    Hi Rudi,

    this fixed the Problem, thanks a lot. After that the addon tells me that it Looks for omxplayer which is not available through the packages. Do you have that also somewhere?



    PS: It seems that I am only the first who asked something for it… 🙂


    Warped Rudi

    I’ve uploaded an omxplayer to the location mentioned above. Our pgrep tool (busybox) does not support some options that are used by this player’s startup script, but a quick test shows that it at least can play a file…



    Hi Rudi,

    I have installed the package but still got nothing. I did not have enough time to check for error messages but will do this (hopefully) next week to come back to you.



Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.