My feedback about Geexbox sources build

Home Forums Feedback My feedback about Geexbox sources build

Tagged: , ,

This topic contains 51 replies, has 4 voices, and was last updated by  Warped Rudi 3 years, 5 months ago.

Viewing 15 posts - 16 through 30 (of 52 total)
  • Author
    Posts
  • #8998

    tomlohave
    Keymaster

    no problem, take your time
    space is no more a problem for me, I have now 1TB only for local build :p

    #9000

    lpraderi
    Participant

    Hi Tom,
    have an error with iso build:

    --2014-11-28 23:45:46--  http://sources.openbricks.org/devel/mpg123-1.15.4-3368.tar.bz2
    Resolving sources.openbricks.org (sources.openbricks.org)... 67.203.12.194
    Connecting to sources.openbricks.org (sources.openbricks.org)|67.203.12.194|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2014-11-28 23:45:47 ERROR 404: Not Found.
    
    \nCan't get mpg123 sources, falling back to repository
    scripts/get: line 119: svn: command not found
    make: *** [rootfs] Error 127
    #9001

    tomlohave
    Keymaster

    Hello,

    install subversion package with apt-get install subversion

    #9005

    lpraderi
    Participant

    Thanks,
    Installed subversion and other new needed -dev packages:
    java, lzma, zfstream
    Also as recommended for other builds on fedora created a
    link for lbbz2 shared lib “ln -s /lib/libbz2.so.1.0.6 /lib/libbz2.so.1.0”
    after an error file not found while building xorriso.
    Now have a new problem building vtuner:
    Make try to fetch http://sources.openbricks.org/devel/vtuner-1.4+hg3ab5e05d0518.tar.bz2,
    but file present on source repo is “http://sources.openbricks.org/devel/vtuner-2.1%2bhgb6fa0d2b133b.tar.bz2”

    #9006

    lpraderi
    Participant

    [Solved]
    File on server is vtuner app (2.1), missing file is linux driver (1.4)
    Installed Mercurial and sources are retrieved from original repo.

    #9437

    lpraderi
    Participant

    Update on my feedback about Build process:

    After some trouble with VM HDD sizes decide to put together a low power notebook based
    on AMD E350 APU as geexbox build machine, first i386 ISO cooked some hours ago
    after 26 compiling hours !!
    Second build with Python ECS4 unicode option enabled took only a couple of hours,
    (mainly the toolchain build took most of the time).
    Till now all works fine with Python 2.7 UCS4 binary, (no more geexbox GUI restarting).
    Will check more deeply and if all goes fine will upload ISO + package repo to MEGA.

    #9442

    lpraderi
    Participant

    Hello,
    I am having some problems trying to install recently compiled ISO for test on a old PC with Nvidia GeForce 6200 video card, after reading forum found post about use nvidia-legacy drivers.
    But fresh compiled package (full build of ISO with Python UCS4) complains against /lib/modules/3.4.4/ not found.
    Examining opkg data the kernel driver module compiled and installed is 3.13.2 (same as distro),
    any help on steps needed to debug cause of issue ?

    #9445

    lpraderi
    Participant

    More about Geforce 6200:

    Tested GeeXbox 3.0 Released iso and nouveau driver work perfectly @ 1920×1080 60 FPS with cpu usage above 5%
    Will try to capture dmesg and Xorg log of both:
    latest iso release with nuveau working w/GF6200 =”http://download.geexbox.org/releases/3.0/geexbox-3.0-i386.iso”
    latest iso release with nuveau nonworking w/GF6200 =”http://download.geexbox.org/releases/3.1/geexbox-3.1-i386.iso”

    #9446

    tomlohave
    Keymaster
    #9452

    lpraderi
    Participant

    Readed and tested … same result GUI does not draw correctly … if resolution is changed
    to ex: 1024×768 (blindly as GUI dont work) settings menu display fine and you can use all
    video setting including video calibration, but when you exit video menu GUI draw problem
    starts again … blinking lower bar and no menu.

    I think is an opengl draw problem, maybe newer version don’t support old hardware the way old version do.
    With Geexbox 3.0 (eden based) all works perfectly 1920×1080@60fps so its not a slow hardware or low mem problem.
    Will add pastebin logs of both distros on same hardware platform.

    geexbox 3.0 dmesg.log: http://pastebin.com/j8TLqxMp
    geexbox 3.0 Xorg.0.log: http://pastebin.com/zueTG0Bt

    geexbox 3.1 dmesg.log: http://pastebin.com/ukzbWb6L
    geexbox 3.1 Xorg.0.log: http://pastebin.com/KchgjD9h

    Hardware Specs:
    Mobo MSI KT880 Delta with Athlon 2200 CPU
    RAM 1GB DDR
    VIDEO Nvidia GeForce 6200 (NV4A) with 256MB of ram DDR

    #9453

    tomlohave
    Keymaster

    just to be sure, did you restart xbmc service after the modification ?

    #9457

    lpraderi
    Participant

    Yes, thomas … every time , and also launched runxbmc script from VT2 manually with no luck.
    Tested some live Linux XBMC distros like xbmcbuntu and same problem exist on all distros
    using frodo and gotham. I belibe its a opengl/mesa lack of support of old hardware.
    Eden Mesa version 2.1 was used on geexbox 3.0, and Frodo mesa 3.0 on geexbox 3.1.

    Did some more research and found this page about Nvidia Pure Video Hardware decoders:
    http://en.wikipedia.org/wiki/Nvidia_PureVideo#Table_of_PureVideo_.28HD.29_GPUs

    Checked on geexbox 3.0 with several test clips and found that using 720p and 1080p H264 video
    CPU goes to 100% and several frames are droped ( OSD info on top of video ).
    On other hand DVD video Mpeg-2 480p/576p playback perfectly 0 frame drops and cpu below 3%
    So I was doing bad assumptions on hardware decoding.
    Anyway opengl/mesa works perfectly on GUI and console up to 1920 x 1080p @ 60 fps

    Conclusion:
    You still can use old Nvidia hardware (Series 6 & 7) to mount a media center with geexbox 3.0
    and playback DVD, SD video and music locally or over lan, display pictures as slideshows
    and some 720p content with software decoding.
    Sadly addons and plugins for eden are not mantained anymore so dont expect youtube video
    or online radios to work.

    #9458

    tomlohave
    Keymaster

    according to http://www.mesa3d.org/envvars.html
    you can pass MESA_GL_VERSION_OVERRIDE=2.1
    maybe it works …
    Maybe we can have too a special version for old hardware (with mesa 2.1) but I need someome to maintain it.
    I have no free time for this

    #9459

    lpraderi
    Participant

    Thank you, will try and return with results.

    I ,ll be glad on help in any form, i’m not an expert … just can help on track problems and test solutions and do some package and iso build process.
    As I mentioned some time ago, the new APUs from intel and AMD will push i386 and x86_64 geexbox usage
    on low power HTPC.

    #9461

    lpraderi
    Participant

    Maybe offtopic, but after 19 hours compiling x86_64 iso I have this message compiling GRUB:

    ...
    checking whether option -mcmodel=large works... no
    configure: error: -mcmodel=large not supported. Upgrade your gcc.
    make: *** [binaries] Error 1
    

    Then enter:

    ./scripts/loadcfg geexbox-xbmc-x86_64-generic
    make clean
    ./scripts/loadcfg geexbox-xbmc-x86_64-generic 
    make
    

    Loaded cfg twice just in case …. and after 19 hours …same error.
    Any chance to solve this without recompiling all packages again ?

Viewing 15 posts - 16 through 30 (of 52 total)

You must be logged in to reply to this topic.