My feedback about Geexbox sources build

Home Forums Feedback My feedback about Geexbox sources build

Tagged: , ,

This topic contains 51 replies, has 4 voices, and was last updated by  Warped Rudi 3 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 52 total)
  • Author
    Posts
  • #7405

    c00ler
    Participant

    Hi,

    I built Geexbox sources successfully under a Fedora environment so I share how I did if someone is interested :

    1- I installeded Fedora 19 XFCE.
    2- I did a yum groupinstall "“Development Tools” "C Development Tools and Libraries"
    3- I did a yum install java (required after I started the compilation)
    4- Go to /home/user and then clone the Geexbox sources by hg clone http://hg.openbricks.org/geexbox
    5- Do an update to point to 3.1 version with a hg update geexbox-3.1
    6- Load a default config to test with a ./scripts/loadcfg geexbox-xbmc-i386-generic (you can check for available platforms by a ./scripts/loadcfg list and choose the one you want, remeber that geexbox runs on many platforms)
    7- make (it will take a lot of time depending on your processor speed and internet connexion).

    Once done, you’ll have a .iso file to install in your HTPC.

    I would like to thank the Geexbox team who did a great job and Thomas Genty (tomlohave) for the precious and quick support during my compilation (Merci beaucoup 😛 )

    Good luck

    #8288

    lpraderi
    Participant

    Hi,
    Want to use a lightweight enviroment to build geexbox inside a Virtualbox VM.
    1 – Downloaded Fedora XFCE 20 Spin Live ISO (and install to virtual drive).
    2 – Yum Install both groups you mention and Java
    3 – Yum Install hg,patch and wget
    4 – hg clone repo and update to 3.1
    5 – load default config for my test HTPC ./scripts/loadcfg geexbox-xbmc-x86_64-generic
    6 – Make Fails with this missing files

    [root@localhost geexbox]# make
    scripts/rootfs
    **** Your system lacks the following tools needed to build OpenBricks ****
    /usr/include/readline/readline.h /usr/include/ncurses.h
    **** You seem to use a fedora system ****
    would you like to yum install the needed tools ? (y/n) y
    Loaded plugins: langpacks
    No package libreadline6-dev available.
    No package libncurses5-dev available.
    Error: Nothing to do
    make: *** [rootfs] Error 1
    

    Checked both ncurses and readline and seems to be installed
    Installed Packages

    Name : ncurses
    Arch : i686
    Version : 5.9

    Name : readline
    Arch : i686
    Version : 6.2
    Release : 8.fc20

    Any clue ?

    #8289

    c00ler
    Participant

    Hi,

    You miss the -devel packages, try :

    yum install *ncurse* *readline*

    this must fix the problem.

    let me know if it helps 😉

    #8290

    Warped Rudi
    Keymaster

    Be aware that the source code is now hosted at: https://github.com/OpenBricks

    #8291

    lpraderi
    Participant

    Thanks for the reply.

    @cooler: Did both, yum install ncurses and readline yum says latest package already installed,
    but still can’t find ncurses.h or readline.h on /usr/include.

    @Warped Rudi: Noticed that and made both repo under /home hg clone (geexbox) and git clone (openbricks) … both makefile gives me the same error of ncurses and readline not installed (Fedora 20 XFCE Spin).

    Edit: [Solved] miss the * on yum install , as cooler says I was missing -dev packages.
    Make menuconfig worked ok , and first test compilation is running.
    Thank you.-

    #8292

    c00ler
    Participant

    Sorry but maybe I said it the wrong way, you must do

    yum install ncurses-devel readline-devel

    Hope this time is clear and it helps

    #8298

    lpraderi
    Participant

    New problem arises:

     Installing mpc (1.0.1-1devx86_64) to root...
    Configuring mpc.
                                 INSTALLDEV  linux-headers  
                                     PACKAGEDEV  linux-headers  
                                         BUILD    linux-headers  
    ccache already installed, skipping...
    make already installed, skipping...
                                             CLEAN    linux  
                                             UNPACK   linux  
    xz: (stdin): Unexpected end of input
    tar: Unexpected EOF in archive
    tar: Unexpected EOF in archive
    tar: Error is not recoverable: exiting now
    

    after 30 minutes compilation stops with this error about linux package , sorry but need more help here. 🙁

    #8299

    tomlohave
    Keymaster

    maybe an error when you have downloaded sources archive for linux.
    try this :

    from geexbox/openbricks tree

    rm sources/linux -rf
    rm .stamps/linux -rf
    make
    #8931

    lpraderi
    Participant

    Hello again,

    I will need some help to build python 2.7 UCS4 opkg instead UCS2 for i386 and x64.
    Maybe build with this option: –enable-unicode=ucs4

    Will be something like this, but dont know exact sintax and
    wich makefile mod to enable compile option:

    ./scripts/loadcfg geexbox-xbmc-i386-generic
    ./scripts/package Python_2.7.1-1_i686

    Thanks in advance, Lpraderi.-

    #8941

    tomlohave
    Keymaster

    have to test before
    Thanks for the info.

    #8974

    lpraderi
    Participant

    Finally I have success on compiling a single Package,
    it took a moderated amount of time and effort (tested for i386 will do x64 later).
    If anyone interested here are the steps needed for Virtualbox:

    1 – Downloaded Fedora XFCE 20 Spin Live ISO (and install to virtual drive - 2.33 Gb).
    2 – Instead of Yum Install Development Tools just installed strictly the needed ones.
      - wget, patch, bison, flex, gcc-c++ (g++), libstdc++-static, perl-Data-Dumper and git (3.74 Gb) 
    3 – git clone openbricks repo 
    4 - load default config for my test HTPC "./scripts/loadcfg geexbox-xbmc-i386-generic" (4.46 Gb)
    5 - run "./scripts/package $PackageName"
    
    5b - In this case I need to add a compile option to Python so an extra step prior package build ...
       - Edit /packages/python/Python/build and add to "do_configure \" the needed option
       -  "--enable-unicode=ucs4"
       - save and run "./scripts/package Python"
    6 - Package and dependencies will be stored in /binaries/binaries.$ARCH/packages (14.6 Gb) :-O

    Will replace opkg, test and report.
    Regards.-

    #8978

    tomlohave
    Keymaster

    yes
    I’m not sure it will have no impact on other packages that depend on python

    #8987

    lpraderi
    Participant

    Replaced opkg Python_2.7.1-1_i686 with ucs4 version,
    now xbmc GUI keep restarting in a endless loop.
    Will do a full OS Build and recheck dependencies.

     
     * print_dependents_warning:    python-beautifulsoup
     * print_dependents_warning:    xbmc
     * print_dependents_warning:    python-simplejson
     * print_dependents_warning:    cryptopy
     * print_dependents_warning:    python-lsb-release
     * print_dependents_warning:    boost
    #8990

    tomlohave
    Keymaster

    well, I think this change can be very invasive. it needs to be tested with a build from scratch

    #8997

    lpraderi
    Participant

    doing it … started 8 hours ago … will update when ready …
    Just a minor update on Build setup for full .iso :

    Yum Install byacc, ncurses-devel, readline-devel and lzma.

    HDD space needed for Python Package Build:
    ——————————————
    build.i386.eglibc folder size 9.46 GB
    build.x86_64.eglibc folder size 11.3 GB

    HDD space needed for Full .iso Build:
    ————————————-
    build.i386.eglibc folder size 24.7 GB and growing … not finished yet.
    build.x86_64.eglibc folder size ?? (will do later).

Viewing 15 posts - 1 through 15 (of 52 total)

You must be logged in to reply to this topic.