Missing audio

Home Forums GeeXboX for PC Missing audio

This topic contains 6 replies, has 3 voices, and was last updated by  rem 7 years, 12 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #942

    rem
    Member

    I’m having a bit of trouble with GeeXbox 2.0

    The sound only works 5-10% of the time I boot up into it.
    However, there are times when it works fine, but this only happens once in 10-15 reboots!

    What happens is that most of the time, the audio doesn’t work at all – it is missing from the menus as well as media playback. It behaves like the audio drivers aren’t loaded before the first Main menu is displayed.
    I’m only an intermediate Linux user so have limited skills in trying to diagnose the problem.

    Laptops I’ve tested it with
    ===========================
    I’m using it with an old HP NC8000 laptop – the specs are –
    http://h18002.www1.hp.com/products/quickspecs/11786_div/11786_div.html.

    I’ve tried it with 3 laptops, two NC8000 and one NC6000 and get the same results.
    They are all based on the Intel 82801DBx/ICH4xx audio controller (and Intel 82855 chipset?).

    GeeXbox versions
    ================
    I’ve tried it with GeeXbox 2.0 boot CD and the USB created with UNetbootin with the same results.
    Note that all three laptops have working audio and work ok with GeeXBox 2.0-alpha2 and earlier versions.

    Similar problem?
    ================
    I’m guessing it may be simialr problem to GeeXboX on ARM SoCs – Analog Sound
    http://www.geexbox.org/forum/topic/analog-sound/

    Where I think the problem may lie
    =================================
    The laptops have buttons for volume up/down/mute and an LED indicator for mute.

    Sequence of events:-

    If I boot GeeXbox in debugging mode.

    After the initial boot. I get a prompt for ‘Root password or Press Control D for normal boot.’.
    Pressing enter or control D seems to have the same effect.
    If I do either, I notice

    LED indicator mute comes on.
    LED indicator mute should go off shortly after – if it doesn’t then the whole GeeXbox session continues without sound.

    Blank screen.
    ‘GeeXbox – Media Center’ splash screen shows for approximately 1 second.
    Blank screen.
    GeeXbox / XMBC main menu shows.

    Things I’ve noticed
    ===================
    F8 – mutes, F9 – volume down , F10 – volume up.

    Pressing ‘s’ to shutdown shows a shutdown and reboot mini menu, but I can’t get to the reboot option using keyboard keys!

    When the audio did work, I noticed that sometimes the LED mute indicator on the laptop and the Mute icon on the top right are sometimes out of step. When This happens I have great difficulty in disengaging the mute!

    Workaround – how I get it the sound to work
    ===========================================
    Slowing the USB2.0 flash drive helps.
    (I slowed it down by inserting a USB1.1 hub between the laptop and flash drive.)
    Using this method, the sound works 80-90% of the time!

    #945

    tomlohave
    Keymaster

    can you try that :
    in /lib/systemd/system/mixer.service
    add this line
    Before=xorg.service
    like this :

    [Unit]
    Description=ALSA mixer configuration

    [Service]
    Type=oneshot
    EnvironmentFile=/etc/audio
    ExecStart=/usr/lib/alsa-utils/alsa-mixer-setup
    RemainAfterExit=yes
    Before=xorg.service

    [Install]
    WantedBy=multi-user.target

    then reboot

    #947

    rem
    Member

    Thanks tomlohave.
    Unfortunately I don’t know how to do what you’re suggesting!
    I suppose I’m more a beginner to intermediate Linux user.
    E.g. I can almost use Puppy, Ubuntu, Suse, Mephis but struggle with CentOS.

    One thing I forgot to mention was that I didn’t use the network because I couldn’t figure out how to get the wireless working – even with the guide in the documentation!
    However, I’ve just tried booting the CD and using the wired ethernet, then followed the bit in
    http://www.geexbox.org/forum/topic/analog-sound/#post-897
    regarding loading the XBMC mixer plugin (I didn’t appreciate the significance of it before) and found the master volume and others were set to zero. Using the mixer help restore the sound.

    But, getting back to your instructions, presumably I can only get at those files by using a secondary pc and ftp in to access/update the files? Bear in mind I only know how to use a wysiwyg editor in Linux.

    #948

    tomlohave
    Keymaster

    No chance with cd , you need a persistent file
    But you can help a little
    switch to vt2, login password
    then
    amixer > /root/test1.log
    return to xbmc with CTRL+ALT+F4
    change your settings for sound, then return to vt2
    amixer > /root/test2.log

    from another computer, access your geexbox via ftp and send us your results ( should be in /root)

    #952

    sickofthesea
    Member

    I’ve had some sound problems. With an HDD (internal) install, if I boot with my 750gb USB External HDD plugged in then Geexbox starts with no sound. If I boot with it unplugged then I have sound. This problem is repeatable 100% of the time. However if I boot from a USB flash install then I have sound with the external HDD also plugged in (and without). Weird – but I know how to avoid it.

    #961

    rem
    Member

    I used the wired ethernet cable and booted up a freshly made USB 2.0 flash drive.

    1st NC8000
    I booted up – no sound and saved the details to amixer-nosound.log
    I then realised the ethernet doesn’t work on this laptop!

    2nd NC8000
    I booted up – no sound and saved the details to amixer1.log.
    I installed the XBMC mixer plugin and saved the results to amixer2-after-installing-xbmc-amixer-plugin.log.
    I adjusted the master volume, then the PCM volume and save to amixer3-after-adjusting-master-and-pcm-vol.log.

    I then shutdown GeeXbox and tried to access the casper-rw contents using this method.
    http://ubuntuforums.org/showthread.php?t=1028564

    The files are in
    http://www.freefilehosting.net/audio1
    (I don’t know how to upload file to this forum.)

    It looked like all volume settings were muted/set to zero.
    By the way – thanks for all the help and v2.0 looks like it runs better (smoother playback) on my laptop.

    #966

    rem
    Member

    I’ve uploaded another 2 files to show what happens when I reboot.

    log4 – reboot – no sound again. The log file is exactly as log1.
    log5 – reboot via a slow USB1.1 hub. Sound works.

    http://www.freefilehosting.net/audio2

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.