latest build for i386

Home Forums GeeXboX for PC latest build for i386

This topic contains 343 replies, has 23 voices, and was last updated by  David75 4 years, 6 months ago.

Viewing 15 posts - 31 through 45 (of 344 total)
  • Author
    Posts
  • #2313

    tomlohave
    Keymaster

    I’ve uploaded an iso containing xbmc-addon-xvdr (https://github.com/pipelka/xbmc-addon-xvdr and https://github.com/pipelka/vdr-plugin-xvdr)

    is someone interesting to test ?

    http://download.openbricks.org/geexbox-devel-20111224-r13686-i386.iso

    0) configure your regional settings (timezone, etc)
    else records won’t work

    1) create our own channels.conf for vdr 1.7 ( -o7 ) (from putty or from vt2)
    for dvb-t ( -ft )in france ( -cFR ) , command line is :

    w_scan -ft -cFR -o7 > /root/channels.conf

    (be patient)

    cp /root/channels.conf /etc/vdr

    (else w_scan –help is your friend 😉 )
    service vdr will start 15s after the creation of /etc/vdr/channels.conf

    2) activate xbmc-plugin-xvdr
    go to system/addons/installed add-ons/pvr clients
    Choose vdr xvdr client and enabled it

    3) in system/livetv/
    – check “always use the channel from the backend”
    – check “enabled”
    – reset the pvr database and confirm

    4) go to live tv
    watch tv 🙂

    #2318

    josch.hh
    Participant

    Latest version is running well for after deactiviting VAAPI -> as already reported in the other posts.

    But there is still a issue with the button mapping of the MCE remote.
    I think there should be a standard mapping for MCE remote available in the internet -> maybe you can integrate this.
    To my mind the MCE remote is the more or less standard remote for PC’s

    #2319

    craigus
    Participant

    Confirm – running well here also.

    This advice from Tom will get the MCE remote working again:

    “with the last devel iso , you can try :
    opkg remove eventlircd
    opkg remove v4l-utils
    reboot
    your remote should work”

    My only real issues atm is that reboot or shutdown are sometimes instantaneous, sometimes take a couple of minutes, unsure why; sometimes wlan0 is not present, but a reboot will fix that.

    Generally it’s working very nicely, used the built-in installer to do a HD install.

    #2322

    josch.hh
    Participant

    MCE remote trick Doesn’t really work for me… anyway i ave to do some more testing.

    But i found an issue after rebooting with XPVR:
    XBMC starts with an error message that the PVR Manager is enabled without having a PVR Client enabled -> which is not true cause the PVR client XPVR is enabled and LiveTV works -> so why this error message….
    Maybe because of the time out in the RUNVDR start script? 15 sec. before vdr is really started … maybe XPVR tell XBMC it is not ready because it can’t connect during the VDR start delay to VDR…. just an idea

    #2325

    lolo
    Participant

    While it was working well on “live usb stick”, I tried to install “geexbox-devel-20111224-r13686-i386” on (another) usb stick but i get stuck on the same error…
    What i did :
    1 – I created a usb stick with iso on it using linux usb creator
    2 – started my computer and, at prompt, selected : “install Geexbox to disk…”
    (at this moment, i get an error : could not open framebuffer: no such file or directory) but it continues
    3 – Inserted another usb stick and replyed yes to begin the install
    4 – selected sdd and replyed two times yes !
    5 – the system run for a while… everything seems fine except at the end I get the 3 followings messages :

    cp: can't stat ' /.root/isolinux/splash.png' : No such file or directory
    cp: can't stat ' /.root/isolinux/vesamenu.c32' : No such file or directory
    cp: can't stat ' /.root/isolinux/help.msg' : No such file or directory
    /tmp/installator/target/boot is device /dev/sdd1
    The installation has been completed!
    Press any keyto reboot the system...

    Obviously, when I start the computer with the stick, I get the “Could not find kernel image: /boot/vesamenu.c32”

    Any idea ?

    #2326

    Draconis2941
    Participant

    WOOT! WOOT!

    MCE remote is working like a charm for me with r13686.

    #2327

    josch.hh
    Participant

    I am wondering that MCE is not working for me .. only the navigation buttons.

    How can this be? Are there different versions of MCE remote?

    #2329

    Draconis2941
    Participant

    That I don’t know. Here’s how mine shows up:

    I: Bus=0003 Vendor=0471 Product=0815 Version=0000
    N: Name=”Media Center Ed. eHome Infrared Remote Transceiver (0471:0815)”
    P: Phys=usb-0000:00:1d.2-2
    S: Sysfs=/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0/rc/rc0/input4
    U: Uniq=
    H: Handlers=kbd event4
    B: PROP=0
    B: EV=100013
    B: KEY=fff 0 0 200 108fc32e 2376051 0 0 0 7 158000 4192 4001 8e9680 0 0 10000000
    B: MSC=10

    #2330

    josch.hh
    Participant

    Same Vendor and Product numbers for my, but doesn’t work.

    #2331

    tomlohave
    Keymaster

    @lolo, please open a new post, and how did you install geexbox from iso with dd or unetbootin ?

    new iso that correct problem while reloading channel data with vdr-geexbox
    http://download.openbricks.org/geexbox-devel-20111226-r13693-i386.iso

    for the remote : same receiver with different remote ?

    #2340

    josch.hh
    Participant

    With the new ISO the XVDR addon problem is NOT gone.
    XBMC still complains during the start that LiveTV is enabled but no PVR client.

    I remove your sleep delay of 15 sec in /usr/bin/runvdr, and voila it works.

    I am sure the XPVR addon waits until it is able to connect successfully to VDR and only then it reports a correct start to XBMC.
    And with 15 sec of delay it sems that it takes to long for XBMC and the result is the error message i got.

    Maybe you can fix this… 🙂

    BTW, for what are the 15sec good for?

    #2346

    tomlohave
    Keymaster

    i have a saa7134 card that need a firmware upload and if you start vdr to early, firmware upload failed.
    If you wait for 15 s, can xbmx reconnect to the pvr client ?

    #2352

    josch.hh
    Participant

    The PVR client has no issue to connect to VDR after it is ready.
    It is only the error message i always get, which does not disappear.

    Don’t you have this error message window too?

    #2353

    josch.hh
    Participant

    BTW, Power off the system doesn’t really work, or takes very long with r13693.
    Over 1-2 mins. Reboot is much faster.

    #2372

    Joe90
    Participant

    Just tested r13693 for vdr, once I had sorted out my channel list (to use correct transponders) perfect in every way 🙂 . Only used for tv watching. Though not tested against any remotes. Well done GB team 🙂

Viewing 15 posts - 31 through 45 (of 344 total)

You must be logged in to reply to this topic.