latest build for i386

Home Forums GeeXboX for PC latest build for i386

This topic contains 343 replies, has 23 voices, and was last updated by  David75 4 years, 6 months ago.

Viewing 15 posts - 301 through 315 (of 344 total)
  • Author
    Posts
  • #4067

    David75
    Participant

    Tried it yesterday night. A bit too tired to be efficient these days.

    So the smbroot works.
    I can’t setup persistence, probably because I’m not doing it right.
    No audio
    forward bug

    Regarding PXE, well the truth is I’ve never been able to find a solution to the NFS problem with windows (no free solution)
    I wanted to try openfiler, but I do not have much time/skills to go that route.

    So basically, I’m not able to get everything from the share.
    I’m able to prepare the stick with a syslinux environment and menu, get the smbroot/rootfs from the share, but not more than that.

    #4068

    tomlohave
    Keymaster

    tested yesterday with intel g33, works
    do you have some logs ? Xorg.0.log ?

    #4069

    tomlohave
    Keymaster

    @david75
    i just test with tftpd32, works very well, without the need of nfs ….

    contact me in private for config files

    #4071

    tomlohave
    Keymaster

    tested with hanewin nfs server for windows, works too

    #4072

    tomlohave
    Keymaster

    r14561 should have sound and remote issues fixed

    #4073

    David75
    Participant

    Sorry if I’m a little less responsive, quite tired… I’ll try to be more responsive tomorrow or this week-end 😉

    Tonight, Portugal-Spain… with tvheadend and geexbox 😉

    #4074

    jarwha
    Participant

    When installing nvidia driver I get an error:
    Running depmod …
    FATAL: Could not rename /lib/modules/3.4.4/modules.devname.temp into /lib/modules/3.4.4/modules.devname: Is a directory
    Done, reboot required

    after reboot XBMC is working! including the remote
    Thanks

    #4075

    tomlohave
    Keymaster

    I’m looking at this now
    thanks

    #4077

    David75
    Participant

    Ok tried 14561
    Is it a ffmpeg version?
    Audio is back
    can’t use the persistence over SMB
    I wonder if it would be possible to get vmlinuz and initrd from the smb share too.

    I have smb or http shares available.
    I don’t want to use tftp/PXE as I do not want to disable DHCP for other computers on my network.

    Thanks

    #4078

    tomlohave
    Keymaster

    yes ffmeg version : still problem with forward ?
    for vmlinuz and initrd, it’s possible with pxe. i have two dhcp servers : one from my box, another for pxe, no conflicts.
    why can’t you have persistence over smb ?

    #4081

    David75
    Participant

    I don’t know for persistence.
    Maybe you could post a full config line as an example?

    I’ll try iPXE again. I’ve always wanted to be able to compile again, but last time I did probably was like 10 years ago…

    Well, libav does a little more than ffmpeg, like Hi10p 😉

    #4118

    David75
    Participant

    I’m still there, lurking, waiting for new releases 😉

     

    In the meantime, played too much with the addons on my R14230 that was stable, then the persistence got full, it created problems and then I broke it.

    Decided to reinstall from new

    Then, I’ve got the annoying forward bug with I never had before with that release and libav (the very first try at Hi10p support)

    I’m not on a good day today, it seems.

    #4119

    David75
    Participant

    Gave r14744 a try (new 64bit release)

    xbmc restarts when browsing drives with large number of folders/files.

    Hi10p: not compatible

    Install is ok, boots properly, localisation (language/timezone) is ok, keyboard vconsole parameter is ok, nvidia driver install is ok.

    #4120

    David75
    Participant

    I’ve got something!

    for some reason, r14230 that was working fine with Hi10p, didn’t after reinstall. Xbmc keeps restarting everytime there’s a skip (rewind or forward)

    For some reason, starting a file directly at a set time, does not create the bug. But when playing it does.

    Then sometimes, a forward is possible during the 2 or 3 first seconds of playing.

    Somehow, there’s a caching problem. The video cache is always 100%, but when you skip, it’s more a filesystem cache or the likes?

    Thing is, in my setup I read files from a smb share. I thought it was not the problem because the same bug appears with files played from an ide drive attached in the comp and ext3 formatted.

    But what I found is that if I play the file from the root folder on the usb drive, no more bug!

    So I guess there’s some filesystem bug somewhere, I wonder why it affects Hi10p only though, as I have other files with higher bitrate that run fine from the same locations. It’s just they do not use the same decoders, they are even GPU decoded.

     

    It still doesn’t explain why r14230 never had the bug prior to that clean reinstall. But at least I have a case where it works. So I guess I/we can start from there.

     

    Ideally, I could use the root folder as a temp to store files played, but that would slow down everything and probably kill that usb key in no time with write wear.

    The other solution would be to have that folder in ram, for speed and write endurance.

    Or just find the cause and get a solution for the problem… But I don’t know where to look at, logs or anything that could help finding a solution.

    I’ve already spent quite a lot of time just finding that out, when it’s so basicly simple…

    • This reply was modified 2 years ago by  Tomtom.
    #4210

    David75
    Participant

    I didn’t post before, but I did try the last two builds. Not for long as they do not decode Hi10p

    I noticed however that r15016 has some troubles navigating through harddrives. It’s slow at times and the system becomes unresponsive.

    wmv decoding seems to be a problem sometimes, something that never happened before.

    Thing is, these problems are not constantly there. So it’s very hard to track.

     

    Regarding building my own versions, I did try openbricks. It was hard just being able to have the build menu. Then in that menu, it’s hard to know what to keep and discard for 2 reasons:

    Same modules seem to be present in many submenus

    There’s no way of knowing dependencies.

     

    So I tried a first compile and it stopped after 3 hours with a message indicating a missing object. I erased everything out of rage. It’s a little strange it is not possible to have a control part that checks everything is there before the long build. Also, I guess I was fed up with the fact that after so many hours of just getting to the first compile, and 3 hours compile I got a lunarian message for a glitch.

    I guess it might have been possible to analyse the log and restart the build from where it stopped. But since it was like 2 weeks ago… I doubt I can do that anymore.

     

    Sorry for the rant 😉

Viewing 15 posts - 301 through 315 (of 344 total)

You must be logged in to reply to this topic.