Keyboard problem

Home Forums Miscellaneous Keyboard problem

This topic contains 6 replies, has 2 voices, and was last updated by  johndee 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10782

    johndee
    Participant

    Hi,
    I am new to GeeXbox but like what I see
    I am having problems installing.
    I can run live from both CD and USB, but whatever I do, TAB from the start screen will not work so I can’t install to anything.
    In case it was a USB problem I have tried both USB and PS2 keyboards without success.
    I have tried both hard drive and 32G usb, both being reckognised by the computer.
    Could anyone help me?
    Thanks, john

    #10795

    tomlohave
    Keymaster

    Hello,
    Maybe there is an extra option in bios ?

    Anyway, if you keyboard works once the system started, you can always install it.
    just connect remotely (see documentation) or stop kodi/xbmc (depending of the version you boot with)
    then umount the device you want to install on it and start installator
    here is what I do ( on a vbox) :

    thomas@servA:~$ telnet 192.168.1.36
    Trying 192.168.1.36...
    Connected to 192.168.1.36.
    Escape character is '^]'.
    
    geexbox login: root
    Password: 
    
    BusyBox v1.24.1 (2016-07-21 16:21:34 CEST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    
    root@geexbox:~# cat /proc/mounts 
    tmpfs /.root tmpfs rw,relatime 0 0
    /dev/loop0 /.squashfs squashfs ro,relatime 0 0
    none /.data tmpfs rw,relatime 0 0
    none / aufs rw,relatime,si=20dcd6eb 0 0
    tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
    sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
    proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
    devtmpfs /dev devtmpfs rw,nosuid,size=1796768k,nr_inodes=209758,mode=755 0 0
    tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
    devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
    tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
    cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd 0 0
    cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0
    cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
    cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
    cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
    cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    hugetlbfs /dev/hugepages hugetlbfs rw,relatime 0 0
    tmpfs /tmp tmpfs rw 0 0
    mqueue /dev/mqueue mqueue rw,relatime 0 0
    fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
    configfs /sys/kernel/config configfs rw,relatime 0 0
    /dev/sda1 /mnt/SATA\040Disk\040#1\040GeeXboX\040(0) ext4 rw,relatime,data=ordered 0 0
    /dev/sr0 /media/GEEXBOX iso9660 ro,nosuid,nodev,relatime,uid=0,gid=0,iocharset=utf8,mode=0400,dmode=0500 0 0
    root@geexbox:~# umount /dev/sda1
    root@geexbox:~# installator

    Here I choose to umount /dev/sda1, to install geexbox on it

    #10796

    tomlohave
    Keymaster

    edit : found some problem with this method, looking at it …

    #10797

    tomlohave
    Keymaster

    Ok that’s because we boot without the ‘nocache’ option.
    Once you boot, send me the results of command line :
    cat /proc/mounts

    #10799

    johndee
    Participant

    Thanks for the help.
    Non of it was any good though. Live, no problem, but trying to install, the keyboard does not work, so I can’t do anything.
    I don’t think it is GeexBox though, I suspect the computer. It was my first use of an emachines I had given, and since I posted I have tried other O/S’s
    Win7 will install but not download, KodiBuntu will install, download some repo’s but not let me install them, Ubuntu hangs on UUUUUUUUU. I have no problems with live O/S though – Puppy is fine.
    If you are interested, it has an E5800 CPU, I have tried changing the Videocard (GT710 and Raedon5400), RAM 2/4/8Gig and 3 different hard drives.
    Whatever combination I tried, the problems were repeatable.
    Thanks again for the advice.
    John

    #10800

    tomlohave
    Keymaster

    ok, so if live boot works correctly, try to connect to geexbox remotly (see http://www.geexbox.org/geexbox-advanced-configuration-login-and-administration/ (telnet part) )

    and please execute this command line :
    cat /proc/mounts

    Then I can send you what to do exactly to install it

    #10842

    johndee
    Participant

    Hi all,

    I can’t even log in to Geexbox though I can see the settings.
    I have decided to give up on that computer.
    A pity, it’s a very small box in spite of having 2 DD3 RAM slots and an E5800 CPU and would be ideal for a media center. It’s a custom M/B so I can’t even replace it. My son thinks it may have been some sort of dumb terminal box and there is probably a setting somewhere in the BIOS which should let it work normally, but if so it’s very well hidden and not obvious.
    Thanks for all the help
    John

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.