Installation impossible

Home Forums GeeXboX for PC Installation impossible

This topic contains 3 replies, has 3 voices, and was last updated by  sickofthesea 7 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #925



    I just tried out to install Geexbox 2.0 on my PC and it doesn’t work 🙁

    the live cd work properly , I can use geexbox without installation. But in the boot menu I haven’t an install option , and when I use [tab] to put the install option , it doesn’t work: geexbox start in live cd mode.

    I tried to do like said in the documentation of the site but I didn’t use grub legacy but grub2 , so I didn’t find how to put a new entry in my grub2 to use geexbox! (I have copied GEEXBOX to /GEEXBOX , has said in the documentation)

    please help me!

    P.S. : scuse me for my poor level of english, I’m French



    That’s because install is no longer supported in GeeXbox 2.0.
    Easiest is to use it with LiveUSB.



    Yes but I don’t know how to add an entry in my Grub2 to boot to the liveUSB (I want to keep my ubuntu working with GEEXBOX)



    In a terminal, type “sudo gedit /etc/grub.d/40_custom” and change the text so it looks similar to this below;

    exec tail -n +3 $0
    # This file provides an easy way to add custom menu entries. Simply type the
    # menu entries you want to add after this comment. Be careful not to change
    # the ‘exec tail’ line above.
    menuentry “GeeXBox 2.0” {
    echo ‘GeeXBox …’
    set root=(hd0,4)
    linux /GEEXBOX/vmlinuz root=/dev/sda5 vga=789 quiet splash loglevel=3
    echo ‘Loading initial ramdisk …’
    initrd /GEEXBOX/initrd

    My linux root partition is on sda5. Change the values on lines 8 & 9 to reflect the partition of your root partition /. i.e. if your root partition is sda2, then line 8 should read “set root=(hd0,1)” and line 9 ……=/dev/sd2….

    Save the file and in the terminal enter “sudo update-grub2”. You MUST do this. You won’t see your new entry listed in the output from this command, however when you reboot it should be in grub2’s list.

    Then please let me know whether or not you are able to save persisitent settings, as I can’t – see my post earlier.

    Thanks & best regards,


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.