FTP not "listening" at IPv6

Home Forums GeeXboX on ARM SoCs FTP not "listening" at IPv6

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Godrigos 10 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11945

    Godrigos
    Participant

    Hi there. I recently updated my geexbox to geexbox-devel-20171203-r8599994 release, on a Cubox-i4Pro.
    Adjusting some things, enabling ip6 for lighttpd, all went well. Then I realized that only ports 22, 80 and 8080 are open for remote access.

    I verified if ftp server was running:

    root@geexbox:~# ps -e | grep ftp
      597 root     /usr/sbin/bftpd -D -c /etc/bftpd.conf
     1188 root     grep ftp

    And it seems fine, but when I checked it better:

    root@geexbox:~# netstat -tlpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      792/kodi.bin
    tcp        0      0 0.0.0.0:56915           0.0.0.0:*               LISTEN      478/rtorrent
    tcp        0      0 0.0.0.0:1876            0.0.0.0:*               LISTEN      792/kodi.bin
    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      597/bftpd
    tcp        0      0 127.0.0.1:8000          0.0.0.0:*               LISTEN      478/rtorrent
    tcp        0      0 0.0.0.0:1250            0.0.0.0:*               LISTEN      792/kodi.bin
    tcp        0      0 :::8080                 :::*                    LISTEN      792/kodi.bin
    tcp        0      0 :::80                   :::*                    LISTEN      640/lighttpd
    tcp        0      0 :::22                   :::*                    LISTEN      1/init
    tcp        0      0 ::1:9090                :::*                    LISTEN      792/kodi.bin

    It seems that it is active but not listening at IPv6. Older version gave me remote ftp access without issue. Is it disabled on build, or can I “renable” it myself?

    Thanks as always for the attention.

    #11946

    Warped Rudi
    Keymaster

    Hmm, bftpd has not been changed for years and looking at it’s source code I’d say that it does not support IPv6 at all.

    #11948

    Godrigos
    Participant

    Oh ok. I may have used sftp with openssh in the previous version. Thanks anyway.

    • This reply was modified 10 months, 2 weeks ago by  Godrigos.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.