[Cuboxi] Old packages

Home Forums GeeXboX on ARM SoCs [Cuboxi] Old packages

This topic contains 4 replies, has 2 voices, and was last updated by  Ao 5 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12437

    Ao
    Participant

    Hi,

    The cryptography package (http://download.geexbox.org/snapshots/geexbox-kodi-imx6-cuboxi/latest/binaries.cuboxi/packages/cryptography_1.6-1_armv7.opk) seems to be too old for the installed version of Kodi: “Your version of the Python cryptography module is too old. You need at least version 1.7. Please upgrade your operating system.”

    Is it possible to update this package?

    I tried to pip install cryptography --upgrade, but it complained about the toolchain not being here. I then tried to clone the mercurial repository (I wanted to update the package version and recompile everything to get only this package and its dependencies), but there’s a 502 Bad Gateway error.

    P.S.: Also, the links for downloading ISO images of geexbox looks broken on https://www.geexbox.org/download/: there are [download id=”22″ format=”1″] in place of actual links.

    #12439

    Warped Rudi
    Keymaster

    Hi Ao,

    we are currently in the situation that nobody is maintaining the web site. Especially the “Download” page is broken and utterly outdated. We abandoned mercurial many years ago. Current sources can be found at GitHub.

    As for crytography, please try this version. It’s the “newest” that will build without changing our environment.

    #12507

    Ao
    Participant

    Hey Warped Rudi,

    Thanks for the update on the “Download” page, but it’s too bad for the website 🙁
    Is this the state of the whole Geexbox community or only for the website?

    And thanks again for the package, it works like a charm!

    #12520

    Warped Rudi
    Keymaster

    I’m afraid it’t the whole Geexbox thing. Pretty much all contributors have lost interest 🙁

    #12548

    Ao
    Participant

    That’s really too bad 🙁

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.