Cubox-i Jarvis – IPv6

Home Forums GeeXboX on ARM SoCs Cubox-i Jarvis – IPv6

Tagged: ,

This topic contains 33 replies, has 3 voices, and was last updated by  Godrigos 1 year, 11 months ago.

Viewing 15 posts - 1 through 15 (of 34 total)
  • Author
    Posts
  • #10466

    Godrigos
    Participant

    Hi there, my ISP recently start using IPv6 and as public IP and a IPv4 behind a CGNAT. So to have any chance of remote access which I use a lot, I need to know if recent versions (Jarvis an on) are IPv6 capable, and if they are, how do I get the IPv6 address from it. I tryed some linux commands but they don’t get me the information I need (ifconfig, curl with some iptracking sites, etc…).
    Any ideas?

    Thanks again.

    #10472

    tomlohave
    Keymaster

    Hello,
    no ipv6 enable : it’s disable on kernels and on others packages.
    And you’re the first to ask.
    Let’s see if we can enable this . But from my side, I can’t test this.

    Cheers !

    #10473

    Godrigos
    Participant

    Ok, if you are up, let’s try then.
    I’ll try to do the testing.

    #10474

    tomlohave
    Keymaster

    yes, but I need a little time for this :

    grep ipv6 project/openbricks/packages/ -r | wc -l
    74

    So there is a little work to do 😉

    #10475

    Godrigos
    Participant

    lol. I see. Well, I can just thank you for now.
    😛

    #10476

    tomlohave
    Keymaster

    building …

    #10477

    tomlohave
    Keymaster

    uploading here (ETL : 4min) :
    http://download.openbricks.org/cuboxi/ipv6/geexbox-devel-20160510-r9c7830b.cuboxi.tar.xz

    md5sum : cb07fcecfdb4ae191923364548169957 geexbox-devel-20160510-r9c7830b.cuboxi.tar.xz

    Please provide feedback

    Cheers

    #10478

    Godrigos
    Participant

    I will test it tomorrow night, as soon as I have any news, i will post it here.

    Cheers!

    #10480

    Godrigos
    Participant

    Hi there, good news I guess.
    ifconfig -a doesn’t show my ipv6 address, but trying with and external site I got it.
    I still have to configure a lot of stuff at work to regain remote access, I probably will have to tunnel my work IPv4 connection through some IPv6 Tunnel Broker to get it going, but you got it man.

    root@geexbox:~# curl icanhazip.com
    2001:1284:f003:3c90:ba5a:f7ff:fe82:9efc
    root@geexbox:~# 
    
    #10481

    Godrigos
    Participant

    By the way. Future releases will have this feature enable right?

    #10483

    Godrigos
    Participant

    Ok some small issues that are poping up. Not even sure if they are related to the ipv6 thing. Flexget no longer can authenticate HTTPS links (some SSL ceetificate issue), removed them to regular HTTP and it’s fine. Trakt addon stoped asking for the pin code and no longer authenticate too, this one I was unable to fix. And the most strange kodi time and date do not update even having a working connection. That is what I noticed till now. I will let you know if any other strange behaviors appear.

    Regards.

    #10484

    Godrigos
    Participant

    I remember an script that could update these certificaes. I’m quite sure that most of these issues are due to invalid certificates. I just can’t remember where is it…

    #10485

    Godrigos
    Participant

    Found it, quite simple actualy. But not enough. rtorrent also having the same certificates issue with https.
    Well, that it for today, lol

    Cheers.

    #10487

    tomlohave
    Keymaster

    ok, let’s see if we can fix all the issues before …
    I’m rebuilding from scratch cause I forget to do the change for an essential lib (libxml2)
    I hope to have this ready this afternoon, then if you can retest …
    Cheers !

    #10490

    tomlohave
    Keymaster
Viewing 15 posts - 1 through 15 (of 34 total)

You must be logged in to reply to this topic.