Analog Sound

Home Forums GeeXboX on ARM SoCs Analog Sound

This topic contains 10 replies, has 6 voices, and was last updated by  Forrest_Gimp 6 years, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #888


    Today I installed the brandnew release 2.0 on my PandaBoard.

    I am quite impressed about the good functionality and the decent skin. Also the performance is better than expected.

    What makes me a little bit clueless is the fact that there is no sound using the analog output. When booting an Ubuntu 11.04 the sound works when selecting the SDP4430 analog audio device.

    When trying the same with XBMC there is no sound at all.

    Does anybody have an idea what might be wrong with my configuration? I tried several settings in System/System/Audio-Hardware but there was no result.

    I would appreciate any advice very much!



    I have exactly the same problem. I’ve tried 2.0 on three totally different machines. No sound on any of them. Sound definitely works on each machine under different OS, just not under GeexBox 2.0.

    What am I doing wrong?

    By the way, each of these machines worked fine under 1.2.





    sound now works (on the 2 machines i’ve tried). i went to ‘programs’ from the main menu, found and installed ‘audio mixer’. when i backed out of the program installer and clicked on the newly installed mixer, i found that every item was muted and at 0%. unmuting and fading up the appropriate items (master, pcm, headphone, etc) solves the problem.

    i did notice some latency between making a change and hearing a change, so be patient. experiment.

    it does beg the question, however, of why sound is broken out of the box.




    michael, on pandaboard by default we enable audio over hdmi. Try changing SOUNDCARD_MODE in /etc/audio to enable the analog outptus (you may also need to change something in the xbmc audio setting).

    joeymorin, can you post some more details on the machines with broken sound? If you can provide the names of the mixers that are muted on boot (as printed in the ‘amixer’ output) we’ll fix this for the next release.



    Dell Inspiron 600m
    Dell Latitude C640
    Toshiba Satellite P30

    in all three cases, EVERY SINGLE item available through ‘audio mixer’ was muted. the list is different for each machine:

    on the C640:
    ‘3D Control – Switch’,0
    ‘Mic Boost (+20db)’,0
    ‘Loudness (bass boost)’,0
    ‘Master Mono’,0
    ‘Simulated Stereo Enhancement’,0



    Davide, thanks a lot for your advice. Unfortunately I do not have a display available that can process audio via HDMI. I just using an old TFT using a HDMI – DVI cable.

    That is what I have tried:

    I changed SOUNDCARD_MODE in /etc/audio to “analog”.

    I have checked which sound device have been recognized by

    cat /proc/asound/cards

    I have got

    0 [SDP4430] …
    1 [PandaHDMI] …

    So I assume basically ALSA does recognize both sound systems.

    Then I played around with the sound settings in System/System/Audio-Settings. I have cycled all possible entries of Audio Output Device. Some settings gave me an error message about not being able to initialize the sound system some did not issue an error message when playing a MP3 song.

    I have also installed the sound mixer application mentioned by joeymorin and unmuted everything.

    But in every case there was no sound available on analog output.

    Do you have more ideas what to try next?



    Perhaps it helps to show what is printed to the debug log when trying to play a song with the “SDP4430” setting:

    Initialize – using alsa device Standards:CARD=SDP4430
    Initialize – pcm_open_lconf, alsa error: -2 -No such file or directory

    Creating a Null Audio Renderer.

    I hope that information helps.



    well, it gets stranger.

    i did a bit more experimenting, and found that occasionally sound will work. sometimes it works through the integrated speakers, sometimes through the headphone jack, sometimes both. sometimes the volume appears normal, sometimes it is so low as to be almost unnoticeable. most of the time however, there is no sound whatsoever: no sound on playback, no ‘clicks’ from the interface. nothing.

    i’d say it works less than 10% of the time. this behaviour appears to be non-deterministic. i tried several things: booting with patch cord in headphone jack, and without. using interface with mouse, and with keyboard. s-video cable plugged in and not plugged in. in each case i tried multiple reboots. in each case whether or not sound worked appears to be completely random. i tried this on both dell laptops.





    I am very glad that my pandaboard now can be more than one of my toys, so I had to donate to a new oss project 😉

    I think the sound problem needs depper inspections. I rechecked it with a fresh install and a other tv, but also got no sound over hdmi. Is there a mailing list where i can ask? Also my cursor and wifi problem remains, should I ask for help by openbricks here?



    You can ask for help on either GeeXboX or OpenBricks dev list indeed.
    If problem really is related to Panda itself, then maybe pandaboard mailing list.



    I had the same problem: video was running great, but no sound. Interestingly I found that removing the loglevel-setting from syslinux.cfg enabled my analog audio even without audio-mixer plugin. (which is great, by the way. I’d recommend including it in the standart-iso!). What I did was changing the line

    append initrd=/ubninit vga=789 persistent quiet splash loglevel=3 persistent


    append initrd=/ubninit vga=789 persistent quiet splash persistent

    Ever since then I had sound (via analog audio, haven’t tested hdmi). Playing around further I found that it keeps working now, even when I set logging back to level 3.

    By the way, what do I have to set it to so there’s no logging at all?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.