Wifi on Panda?

December 10th, 2012

Home Forums GeeXboX on ARM SoCs Wifi on Panda?

This topic contains 22 replies, has 4 voices, and was last updated by  tomlohave 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #5516

    moon127
    Member

    I’ve just installed Geexbox 3.0 on my ARM Pandaboard and have it working well using the Ethernet port.

    I’d like to connect to samba shares using wifi but despite reading the docs on configuring /etc/network I don’t seem to be able to get wireless connected.

    Does wifi work on Panda?

    #5601

    tomlohave
    Moderator

    use dhcpc instead of connman for wifi on panda (edit /etc/network), it should work.

    #5615

    a649m
    Member

    shouldn’t it be “udhcpc”?

    Have the same issue and tried it with dhcpc before which didn’t work and checked the documentation later that I forgot the ‘u’…

    Haven’t tried it since then.

     

    I have another question to WLAN on pandaboard: should the WPA key be in plain text or in hex format?

    #5645

    tomlohave
    Moderator

    right : udhcpc.

    for WPA : I use the hex key

    #5920

    a649m
    Member

    Still doesn’t work for me.

    Is it a driver problem? The displayed MAC address (via ifconfig wlan0) is DE:AD:BE:EF like it is not initialized.

    Other systems (e.g. Linaro Ubuntu build) show the MAC correct)

    Is there something I could do about this?

    #5928

    tomlohave
    Moderator

    did you install package udhcpc ?

    #6081

    uffe
    Member

    I also have problems with getting the wifi to work on the pandaboard. Changing to udhcpc did not help, although I did not do any attempt to install it. Could you please enlighten on how to do that?

    #6089

    tomlohave
    Moderator

    install the package udhcpc first then it should work

    #6098

    uffe
    Member

    When I try “opkg install udhcpc” it says I already have the newest version.

    I’ve now also tried all settings combinations I can think of in the ‘network’ file without success. This is the content of my best guess:

    # Network configuration

    # Backend software to use for network management (e.g. “connman”)
    NETWORK_BACKEND=”udhcpc”

    # “LAN” or “WLAN” or “” (default is “” <–> “LAN”)
    NETWORK=”WLAN”

    # Network interface name or address (e.g. “eth0″ or “00:0d:56:ec:ba:0c”)
    IFACE=”wlan0″

    # Static IP address (“” for DHCP) in CIDR format (e.g. “192.168.1.1/24″)
    ADDRESS=””

    # Network gateway (e.g. “192.168.1.254”)
    GATEWAY=””

    # List of DNS servers (e.g. “192.168.1.253 192.168.1.254″)
    # This will override the DNS servers from DHCP
    DNS_SERVER=””

    SSID=”FRITZ!Box Fon WLAN 7360″

    # “true” or “”
    HIDDEN=”false”

    # “WEP” or “PSK” or “” or “RSN”
    SECURITY=”RSN”

    PASSPHRASE=”<My WPA2 HEX code>”

    # set to “” to disable NTP
    TIMESERVERS=”0.geexbox.pool.ntp.org 1.geexbox.pool.ntp.org 2.geexbox.pool.ntp.o
    rg 3.geexbox.pool.ntp.org”

    # Services to be started at boot time
    TELNET_SERVER=”true”
    FTP_SERVER=”true”
    HTTP_SERVER=”false”
    SAMBA_SERVER=”false”

    # Use Zeroconf service discovery
    ZEROCONF=”true”

    # Static Samba shares can be defined as shown in the commented examples below,
    # where <%>,<@>,<&>,<#> field separators must be present as shown (Note that
    # the password cannot contain  these special delimiters):

    #STATIC_SMB=”username<%>password<@>ip<&>myservername<#>share1<#>share2<#>share3

    #STATIC_SMB=”<%><@>ip<&>myservername<#>share1″

    #WAIT_FOR_SLOW_DEVICE=”false”

     

     

    #6099

    tomlohave
    Moderator

    Ok,

    let me check,

    I have pushed some changes to xbmc, now we use version 12.1 for panda too

    I will retest wifi on panda

     

    #6103

    tomlohave
    Moderator

    wifi works out of the box here.

    cat /etc/network

    # Network configuration# Backend software to use for network management (e.g. “connman”)

    NETWORK_BACKEND=”udhcpc”

    # “LAN” or “WLAN” or “” (default is “” <–> “LAN”)

    NETWORK=”WLAN”

    # Network interface name or address (e.g. “eth0″ or “00:0d:56:ec:ba:0c”)

    IFACE=”wlan0″

    # Static IP address (“” for DHCP) in CIDR format (e.g. “192.168.1.1/24″)

    ADDRESS=””

    # Network gateway (e.g. “192.168.1.254”)

    GATEWAY=””

    # List of DNS servers (e.g. “192.168.1.253 192.168.1.254″)

    # This will override the DNS servers from DHCP

    DNS_SERVER=””

    SSID=”Livebox-0614″

    # “true” or “”HIDDEN=””

    # “WEP” or “PSK” or “” or “RSN”

    SECURITY=”PSK”

    PASSPHRASE=”my_key”

    # set to “” to disable NTP

    TIMESERVERS=”0.geexbox.pool.ntp.org 1.geexbox.pool.ntp.org 2.geexbox.pool.ntp.org 3.geexbox.pool.ntp.org”# Services to be started at boot time

    TELNET_SERVER=true

    FTP_SERVER=true

    HTTP_SERVER=”false”

    SAMBA_SERVER=”false”

    # Use Zeroconf service discovery

    ZEROCONF=”true”

    # Static Samba shares can be defined as shown in the commented examples below,# where <%>,<@>,<&>,<#> field separators must be present as shown (Note that# the password cannot contain  these special delimiters):

    #STATIC_SMB=”username<%>password<@>ip<&>myservername<#>share1<#>share2<#>share3″

    #STATIC_SMB=”<%><@>ip<&>myservername<#>share1″WAIT_FOR_SLOW_DEVICE=”true”

    iwconfig :

    wlan0     IEEE 802.11abgn  ESSID:”Livebox-0614″
    Mode:Managed  Frequency:2.437 GHz  Access Point: 00:19:70:92:75:AC
    Bit Rate=65 Mb/s   Tx-Power=20 dBm
    Retry  long limit:7   RTS thr:off   Fragment thr:off
    Encryption key:off
    Power Management:on
    Link Quality=43/70  Signal level=-67 dBm
    Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
    Tx excessive retries:0  Invalid misc:60   Missed beacon:0

    eth0      no wireless extensions.

    # ping http://www.google.fr -c2
    PING http://www.google.fr (173.194.78.94): 56 data bytes
    64 bytes from 173.194.78.94: seq=0 ttl=47 time=29.084 ms
    64 bytes from 173.194.78.94: seq=1 ttl=47 time=35.401 ms

    http://www.google.fr ping statistics —
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max = 29.084/32.242/35.401 ms

    #6104

    tomlohave
    Moderator

    [   10.262084] wlan0: authenticate with 00:19:70:92:75:ac
    [   10.277923] wlan0: send auth to 00:19:70:92:75:ac (try 1/3)
    [   10.281249] wlan0: authenticated
    [   10.283538] wlan0: associate with 00:19:70:92:75:ac (try 1/3)
    [   10.287963] wlan0: RX AssocResp from 00:19:70:92:75:ac (capab=0x431 status=0 aid=2)
    [   10.361724] wl12xx: Association completed.
    [   10.386627] wlan0: associated

    #6107

    uffe
    Member

    Thanks for all the information. It still does not work though, I’m afraid… My theory is that the wireless module is loaded too late. I see from your post that already at 10 seconds the connection is made. On my pandaboard it takes 40 seconds just to load it:

    # [   40.555480] wl12xx: loaded

    I have pandaboard rev A3 (not ES), can that make a difference?

    #6108

    tomlohave
    Moderator

    Can you start net-udhcpc manually and post the results ?

     

    #6109

    uffe
    Member

    I guess you mean “udhcpc”? This is what I get (last three rows are continuously repeated):

    # udhcpc -i wlan0
    udhcpc (v1.21.0.git) started
    Sending discover…
    udhcpc: sendto: Network is down
    Read error: Network is down, reopening socket
    Sending discover…
    udhcpc: sendto: Network is down
    Read error: Network is down, reopening socket

     

     

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.

Comments are closed.