VDR XVDR Client: Can't load DLL

Home Forums XBMC and Plugins VDR XVDR Client: Can't load DLL

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  cschweden 2 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7934

    svenhenry
    Member

    Hello,

    i have a problem with the plugin VDR XVDR Client.
    I searched on the internet, but i can’t find a solution.

    The xbmc.log:

    20:25:05 T:1609557088  NOTICE: PVRManager - starting up
    20:25:05 T:1643111520  NOTICE: Thread PVRManager start, auto delete: false
    20:25:05 T:1626334304  NOTICE: Thread PVRClient start, auto delete: false
    20:25:07 T:1736438880  NOTICE: Thread BackgroundLoader start, auto delete: false
    20:25:07 T:1736438880  NOTICE: Thread JobWorker start, auto delete: true
    20:25:09 T:1968030240  NOTICE: Previous line repeats 2 times.
    20:25:09 T:1968030240 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 8
    20:25:12 T:1652552800 WARNING: Previous line repeats 1 times.
    20:25:12 T:1652552800  NOTICE: PVRManager - stopping
    20:25:12 T:1652552800  NOTICE: PVRManager - starting up
    20:25:12 T:1626334304  NOTICE: Thread PVRManager start, auto delete: false
    20:25:12 T:1643111520  NOTICE: Thread PVRClient start, auto delete: false
    20:25:12 T:1669330016  NOTICE: Thread BackgroundLoader start, auto delete: false
    20:25:12 T:1643111520 WARNING: Unable to resolve: XBMC_VDR_xvdr.pvr ADDON_Announce, reason: /usr/share/xbmc/addons/pvr.vdr.xvdr/XBMC_VDR_xvdr.pvr: undefined symbol: ADDON_Announce
    20:25:12 T:1643111520   ERROR: Unable to resolve exports from dll /usr/share/xbmc/addons/pvr.vdr.xvdr/XBMC_VDR_xvdr.pvr
    20:25:12 T:1643111520 WARNING: UpdateAndInitialiseClients - failed to create add-on VDR XVDR Client, status = 6
    20:25:12 T:1643111520 WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on VDR XVDR Client, disabling it
    20:25:12 T:1773974624  NOTICE: Thread AddonStatus pvr.vdr.xvdr start, auto delete: true
    20:25:46 T:1968030240  NOTICE: Samba is idle. Closing the remaining connections

    I hope you can help me.

    Many thanks!

    #7935

    svenhenry
    Member

    vdr seems to running normally:

    # systemctl |grep vdr
    vdr.service                                                                                                        loaded active running   Video Disk Recorder
    
    #7943

    tomlohave
    Keymaster

    on which platform ?
    I have upgraded packages but it won’t work for i386, x86-64 unless we switch to gotham

    #7953

    svenhenry
    Member

    The XBMC version is XBMC 13.0-BETA3 Git:Unknown (Compiled: Apr 16 2014) and it runs on a cubox-i4pro.
    I hope this will help.
    Thanks!

    #7995

    svenhenry
    Member

    any idea, how i can solve this?
    Thanks

    #8059

    svenhenry
    Member

    It works now!

    Thanks for the package update @tomlohave.
    After the update, i can start the plugin xvdr.

    But, when i try to watch a channel, i’l got the error “all tuners busy”.

    I adjusted the diseqc.conf in /etc/vdr to:

    # port 1
    S19.2E  11700 V  9750  t v W15 [E0 10 23] W15 [E0 10 22] W15 t
    S19.2E  99999 V 10600  t v W15 [E0 10 23] W15 [E0 10 22] W15 T
    S19.2E  11700 H  9750  t V W15 [E0 10 23] W15 [E0 10 22] W15 t
    S19.2E  99999 H 10600  t V W15 [E0 10 23] W15 [E0 10 22] W15 T
    
    # port 2
    S13E  11700 V  9750  t v W15 [E0 10 23] W15 [E0 10 26] W15 t
    S13E  99999 V 10600  t v W15 [E0 10 23] W15 [E0 10 26] W15 T
    S13E  11700 H  9750  t V W15 [E0 10 23] W15 [E0 10 26] W15 t
    S13E  99999 H 10600  t V W15 [E0 10 23] W15 [E0 10 26] W15 T
    
    # port 3
    S23.5E  11700 V  9750  t v W15 [E0 10 27] W15 [E0 10 22] W15 t
    S23.5E  99999 V 10600  t v W15 [E0 10 27] W15 [E0 10 22] W15 T
    S23.5E  11700 H  9750  t V W15 [E0 10 27] W15 [E0 10 22] W15 t
    S23.5E  99999 H 10600  t V W15 [E0 10 27] W15 [E0 10 22] W15 T
    
    # port 4
    S28.2E  11700 V  9750  t v W15 [E0 10 27] W15 [E0 10 26] W15 t
    S28.2E  99999 V 10600  t v W15 [E0 10 27] W15 [E0 10 26] W15 T
    S28.2E  11700 H  9750  t V W15 [E0 10 27] W15 [E0 10 26] W15 t
    S28.2E  99999 H 10600  t V W15 [E0 10 27] W15 [E0 10 26] W15 T

    And it works :).

    #8069

    cschweden
    Participant

    Same for me, bombed the family’s TV today… I,ve updated to XBMC13 and got this DLL error message. Any solution?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.