vdr can't find usb tv tuner on rpi

April 25th, 2013

Home Forums GeeXboX on ARM SoCs vdr can't find usb tv tuner on rpi

This topic contains 12 replies, has 2 voices, and was last updated by  pootler 1 year, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #6340

    pootler
    Member

    hello – new to the forums :)

    I’ve come across from openelec because i am trying to find a Pi distro that handles live tv better than tvheadend on the Pi at the moment.

    With vdr built in by default i was hoping I might be able to try Geexbox.

    My Linux knowledge is limited , but I am struggling to get Vdr to recognise my tv usb tuner,

    it is a hauppauge twin dvb-t.

    I have added the latest firmware for this device ( dib0700 1.2fw) to the firmware folder, but when i run w_scan according to your pages, it says it ‘no terrestrial tuner found” – or words to that effect?

    I do not have the front end running whilst doing this and live tv is not enabled.

    Is there anything I have missed ? – I was looking forward to trying a reliable live tv  service with xbmc

    Do I need more driver info for this device?- if so is there anyone who could provide details – in words of one or two syllables please :)

    Many thanks

    pootler

     

    #6341

    tomlohave
    Moderator

    hello,

    first for Pi, use the latest devel snapshot : here : http://download.geexbox.org/snapshots/geexbox-xbmc-bcm2708-raspberrypi/

    then post your logs.tct file  just to be sure your device is well recognized

    (switch to tty2 (see doc) then execute : send-logs

    note the pastebin link)

    #6343

    pootler
    Member

    Hi tom thanks for the reply .

    Now – I need you to imagine something – you have in front of you an 8 year old child who has limited knowledge of linux and command line but curiosity and willing.

    I am at the other end of the age spectrum but thats how I need to be treated :)

    I did do ‘dmesg’ which gave me a list of things including a line where it said it had a problem with the adapter.

    Sorry, but with your dummy hat on can you explain exactly how to do what you are asking?

    Thank you for your patience

    pootler

     

    #6344

    tomlohave
    Moderator

    ok, so let’s go with 8 year old child ;-)

    as I can see you know how to switch to vt2 and enter a command line (you did it for dmesg command line)

    so please execute this command line : (assuming you have a working ethernet connexion)

    send-logs

    you should see some lines and one that contains a link to pastebin, please send me this link

    this command send logs to pastebin. it’s more easy for me to see where is your problem

    Regards

    #6349

    pootler
    Member

    Hopefully this is what you mean

    http://pastebin.com/WagBMG4P

    thanks tom

    #6350

    tomlohave
    Moderator

    exactly ;-)

    I have found one problem with kernel config :

    # CONFIG_DVB_DIB7000M is not set
    # CONFIG_DVB_DIB7000P is not set

    I’m building it (enabling this 2 modules) and will post a link to downlaod it and install it later in the day

    #6353

    tomlohave
    Moderator

    can you try this kernel : http://download.openbricks.org/pi/linux_3.6.11+e3f09be5f6-1_armv6.opk

    so install it ; switch to vt2, then do :

    opkg install –force-reinstall –force-overwrite http://download.openbricks.org/pi/linux_3.6.11+e3f09be5f6-1_armv6.opk

    depmod -a

    reboot

    then send-logs after the reboot

    #6356

    pootler
    Member

    Hi tom,

    I tried this ( I presumed the line with the download link are one ‘line’ – if you see what I mean)

    Anyway it downloaded the stuff and then when I depmod-a gave me this?

    Downloading http://download.openbricks.org/pi/linux_3.6.11+e3f09be5f6-1_armv6.opk.
    Installing linux (3.6.11+e3f09be5f6-1) to root…
    Configuring linux.
    # depmod -a
    depmod: WARNING: could not open /lib/modules/3.6.11/modules.order: No such file or directory
    depmod: ERROR: failed to load symbols from /lib/modules/3.6.11/kernel/drivers/leds/._led-class.ko: Exec format error
    depmod: WARNING: could not open /lib/modules/3.6.11/modules.builtin: No such file or directory

    #6357

    tomlohave
    Moderator

    ok,

    strange for led

    did you reboot ?

    can you see your hardware now ?

    do you have some logs ?

    #6358

    pootler
    Member

    Hi tom,

    think hardware might be being recognised

    tried to engage vdr add-on and vnsi client.

    System seems to have crashed and behaves very strangely?

    Anyway think I am still able to get in to get logs

    http://pastebin.com/gTsau9AX

    #6359

    tomlohave
    Moderator

    Hum, from what I see, it seems to work.

    Don’t know why xbmc hangs, do not activate two frontends for pvr, choose xvdr or vnsi

    another build should be ready tomorrow, including the fix for your hardware, can you test it ?

    Regards

    #6361

    pootler
    Member

    Hi tom – thanks for your time and patience.

    I’ll look for the latest snapshot tomorrow.

    When I said I had engaged vdr and vnsi, I meant that I made BACKEND =vdr in /etc/pvr.config, and then enabled vnsi client.

    I tried it again and can confirm it hangs everything.

    Out of curiosity, I then made tvheadend the default backend and when I enabled tvheadend client ( after having disabled vdr client) it crashed again.

    Curious – will let you know how the new snapshot does.

    thanks again

    pootler

    #6378

    pootler
    Member

    Tom – have just tested latest snapshot ( 1st May)

    had to put 1.2 firmware back in to get any ir remote

    still no luck with vdr – system crashes with vnsi plugin

    with xvdr plugin gets half way there but can see from no lights on the dongle that it is not activating the tuner.

    crashes with tvheadend as well

    Ahh well :) – thanks for all your help.

    back to openelec again

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Comments are closed.