[ solved ] Telnet connection closed by foreign host

February 17th, 2013

Home Forums GeeXboX on ARM SoCs [ solved ] Telnet connection closed by foreign host

This topic contains 5 replies, has 3 voices, and was last updated by  Umberto 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5893

    Umberto
    Member

    Hi,

    I got GeexBox running on a Raspberry Pi but for some reason I cannot connect to GeexBox/Pi using telnet. Connection is established but then immediately closed. The response is as follows:

    telnet 192.168.1.46 9023
    Trying 192.168.1.46…
    Connected to geexbox.home.
    Escape character is ‘^]’.
    Connection closed by foreign host.

    I used the geexbox-devel-20130201-r15822.raspberrypi.tar.bz2 build to install GeexBox on a SD card.

    I have no way to debug this problem since I’am not able to get the vt2 terminal as well (using CTR+ALT+F2). Most likely ’caused by the Apple keyboard I’m using where the F2 is a sort of ‘sub’ key (which required the ‘Fn’ key). Using the CTR+ALT+FN+F2 doesn’t help either.

    Please help!

    Kind regards,

    Umberto

     

    #5894

    tomlohave
    Moderator

    from telnet.socket

    EnvironmentFile=/etc/network
    ExecStartPre=/usr/bin/test ${TELNET_SERVER} = true

    Please, check your /etc/network file

    #5895

    Umberto
    Member

    Thanks for your quick response. Telnet is enabled in my /etc/network file:

    TELNET_SERVER=”true”

    The things I changed in this file is the SSID(=my wifi network), SECURITY(=PSK), PASSPHRASE(=my wifi password), NETWORK(=WLAN), IFACE(=wlan0).

    Also, GeexBox/Pi has internet connection (via a WiFi dongle) since I can use the weather feature.

    One thing I noticed is that my DNS is set to 127.0.0.1. Don’t know if this relates to the problem.

    Regards,

    Huub

    #5957

    clooky
    Member

    I had exactly the same problem. I think this was a bug which seems having been fixed in the last snapshot. I tried it today and I can now connect through telnet. By the way I don’t know why you tried port 9023, it is working using the default port.

    Just try the last release and tell us if this is ok for you too.

    #5958

    tomlohave
    Moderator

    that was solved by Rudi (problem in kernle config)

     

    #5964

    Umberto
    Member

    Thanx for the info. I’ll try it out and let you know…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Comments are closed.