Remote Control (RC6)

February 20th, 2012

Home Forums GeeXboX for PC Remote Control (RC6)

This topic contains 14 replies, has 3 voices, and was last updated by  weilah 2 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3053

    weilah
    Member

    Hi again!

    I’m trying to configure my Remote Control, i’ve been reading around but i haven’t find any instructions.
    What should i do to configure it?

    Just connecting the usb receiver seems to cause no effect at all. The remote control is a typical RC6 remote, (usb, infrared), actually is a Acer Remote (803V).

    Is there anybody who has set up his/her remote controller?

    Thank you

    #3059

    tomlohave
    Moderator

    what returns command lines :
    lsusb
    cat /proc/bus/input/devices

    #3067

    weilah
    Member

    lsusb:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 002: ID ffff:ffff
    Bus 006 Device 002: ID 147a:e017 Formosa Industrial Coumputing, Inc. eHome Infrared Reciver

    So it seems to be on the Bus 006 Device 002.

    the comand line cat /proc/bus/input/devices:
    (i copy just the interesting part)

    I: Bus=0003 Vendor=147a Product=e017 Version=0110
    N: Name=”Media Center Ed. eHome Infrared Remote Transceiver (147a:e017)”
    P: Phys=usb-0000:00:1d.1-2
    S: Sysfs=/devices/pci0000:00/0000:00:1d.1/usb6/6-2/6-2:1.0/rc/rc0/input8
    U: Uniq=
    H: Handlers=kbd event8
    B: PROP=0
    B: EV=100013
    B: KEY=fff 0 0 200 108fc32e 2376051 0 0 0 7 158000 4192 4001 8e9680 0 0 10000000
    B: MSC=10

    thanks!

    #3071

    tomlohave
    Moderator

    do you have some code when you execute :
    evtest /dev/input/event8
    — press keys on your remote , ctrl+c to abord —-

    #3075

    weilah
    Member

    nothing happens….

    ps: i tested the remote control under windows and it works properly

    #3076

    weilah
    Member

    Dr. Tom! xD

    How can I continue?

    #3077

    tomlohave
    Moderator

    can you do this : unplugg your remote and replug it ,
    post the result of dmesg please

    #3078

    weilah
    Member

    should i copy all these lines? or just the last ones?

    #3080

    tomlohave
    Moderator

    just the last ones (20)

    #3081

    weilah
    Member

    ok, sorry about my incompetence.. i’ve dropped the result of dmesg in a file:

    dmesg >> file

    but now i’m trying to take away this file and i can not do it!! Can i reach the file in the pen drive via Ubuntu?
    I tried to copy the file from GeexBox console to the Ubuntu partition but I can’t!

    #3082

    weilah
    Member

    This are the last lines related with the Remote….it seems to register quite good…but i dont understand all:

    usb 6-2: USB disconnect, device number 2
    usb 6-2: new low-speed USB device number 3 using uhci_hcd
    Registered IR keymap rc-rc6-mce

    input: Media Center Ed. eHome Infrared Remote Transceiver (147a:e017) as /devices/pci0000:00/0000:00:1d.1/usb6/6-2/6-2:1.0/rc/rc1/input10

    rc1: Media Center Ed. eHome Infrared Remote Transceiver (147a:e017) as /devices/pci0000:00/0000:00:1d.1/usb6/6-2/6-2:1.0/rc/rc1

    input: MCE IR Keyboard/Mouse (mceusb) as /devices/virtual/input/input11
    rc rc1: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
    mce 6-2:1.0: Registered Formosa21 SnowflakeEmulation with mce emulator interface version 1
    mce 6-2:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x0 active)

    #3083

    weilah
    Member

    thanks

    #3086

    weilah
    Member

    no more ideas out there?

    #3492

    brightpuma
    Member

    Hi Weilah, did you ever get your remote working?

    #3501

    weilah
    Member

    Nope…. it was a weird thing… do you have the same remote?

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Comments are closed.