[Solved] Pyload on Geexbox ??

Home Forums GeeXboX on ARM SoCs [Solved] Pyload on Geexbox ??

This topic contains 15 replies, has 5 voices, and was last updated by  juanlucky 1 day, 12 hours ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #5345

    vince122
    Member

    Hello there !!

    I’m actually using Geexbox on my cubox : this is so great, and faster than the solid-run prebuilt ubuntu+geexbox images !!
    Thanks to all developers !

    I would like to turn my cubox into a http downloader. Before, I was using pyload over my cubox, but now I can’t because of missing libs.

    Did someone already tried to install it ?? Would it be possible to get these libs working on geexbox ??

    Thanks again,
    Vince

    #5348

    tomlohave
    Keymaster

    Hello,

    I am adding it, (no ssl for now but i can remotely login)

    should be ready tonight

    Regards

    #5349

    tomlohave
    Keymaster

    done :

    http://hg.openbricks.org/openbricks/rev/ad07d6426595

    wait for the bot to build a new snapshot …

     

    #5350

    vince122
    Member

    Wooow you’re so rapid !!

    I’ll be testing in the next hours, I’ll let you know,
    THANKS GUY YOU ROCK !!!!!

    #5351

    vince122
    Member

    Sorry but.. Does “mercurial” package is provided with geexbox 3.0 😡 ?
    I can’t type the command “hg”.. Do we have something to do after installing image provided for Cubox ?

    Maybe I didn’t understood well the usage of openbricks source..
    Would you help me ? Sorry but I’m new in this distrib..

    Thanks again,
    Vince.

    #5352

    tomlohave
    Keymaster

    openbricks is a toolchain to cross compile packages

    installing GeexBox, you have no dev packages to build your own packages

    so you should start with a more generic distro like ubuntu (the one I use) to build geexbox using openbricks

    #5356

    vince122
    Member

    Okay fine ! The build is launched !

    Reassure me : The build can be done on any physical machine (x86 or x64 arch) ?

    Thanks again for your reactivity !

    #5360

    tomlohave
    Keymaster

    it should …

    #5370

    vince122
    Member

    Okay ! Still compiling..

    I’ve downloaded devel version, installed packages, everything working !!!

    Thanks a lot ! I’m hurry to build mine !
    Vince

    #5374

    tomlohave
    Keymaster

    🙂

     

    #8623

    bananasplit
    Participant

    Hi!

    I just installed pyLoad on geexbox and it works wonderful!

    But, how can I configure an automatic start at every boot? Can somebody help me – I can do many things on linux, but never configured an automatic start.

    Thanks

    bananasplit

    #11279

    juanlucky
    Participant

    Hello,
    I reopen this thread because I tried to get pyload working on geexbox (latest version of 28/11).
    So I got the package installed with opkg install pyload and then initialize it using the cmd pyLoadCore.py -s.

    I’ve got the following error ImportError: pycurl: libcurl link-time ssl backend (openssl) is different from compile-time ssl backend (none/other).

    I tried the solution explained here (Uninstall, export PYCURL_SSL_LIBRARY=openssl, reinstall the package) but with no results…
    It seems that the package pycurl is not compiled with the default option on geexbox : openssl.

    Any idea how to fix the problem ? Would be great to get a pyCurl package pre-compiled for the default configuration of geexbox.
    🙏

    #11280

    tomlohave
    Keymaster

    Hi,
    on which platform ?
    I have to rebuild from scratch since last changes made by Rudi and I want to pick the good one 😉

    #11291

    juanlucky
    Participant

    Hi Tom,
    I’m using geexbox on cubox-i (imx6).
    Bye

    #11293

    Warped Rudi
    Keymaster

    Was this a fresh installation or an upgrade of an older one? If the latter, you might try a forced re-install of the pycurl package. Otherwise we probally need to rebuild pycurl with the option you mentined.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.