inadyn-mt on GeexBox

Home Forums GeeXboX on ARM SoCs inadyn-mt on GeexBox

This topic contains 41 replies, has 3 voices, and was last updated by  Warped Rudi 1 week, 3 days ago.

Viewing 12 posts - 31 through 42 (of 42 total)
  • Author
    Posts
  • #10715

    Godrigos
    Participant

    Or even better… systemctl enable inadyn-mt, but obviously a post installation solution (if it works).
    Not sure if a package can be installed with boot start already enabled… Can it?

    #10716

    Warped Rudi
    Keymaster

    If you provide a *.service file in your_package/unit, the service is enabled by default. But maybe something is wrong with that file. I.e. service started too early or so. What does systemctl status your_service say?

    #10717

    Godrigos
    Participant

    The inadyn-mt.service is in my_package/unit and systemctl status inadyn-mt says:

    root@geexbox:~# systemctl status inadyn-mt
    ● inadyn-mt.service - Inadyn-mt a Simple Dynamic DNS client
       Loaded: loaded (/usr/lib/systemd/system/inadyn-mt.service; disabled; vendor preset: enabled)
       Active: inactive (dead)

    Any ideas?

    #10718

    Warped Rudi
    Keymaster

    Argghh! Please make sure that the unit/inadyn-mt.service has Unix line endings. For some strange reason, our original inadyn.service (which you probably used as template) uses DOS format 🙁 Then rebuild and reinstall the package.

    #10719

    Godrigos
    Participant

    LoL. This line ending thing follows me for a long time, a C++ code I developed recently had te same issue between systems (Windows / Unix Like). Will do as you suggests and let you guys know.
    Thanks.

    #10720

    Godrigos
    Participant

    Hi there.
    Problem solved. Line endings were the problem.

    root@geexbox:~# systemctl status inadyn-mt
    ● inadyn-mt.service - Inadyn-mt a Simple Dynamic DNS client
       Loaded: loaded (/usr/lib/systemd/system/inadyn-mt.service; disabled; vendor preset: enabled)
       Active: active (running) since Mon 2016-06-27 19:41:53 BRT; 1 day 22h ago
     Main PID: 1012 (inadyn-mt)
       CGroup: /system.slice/inadyn-mt.service
               └─1012 /usr/bin/inadyn-mt
    
    Jun 27 19:41:53 geexbox inadyn-mt[1012]: Mon Jun 27 23:41:53 2016: W:LANG: Cann....)Jun 27 19:41:53 geexbox inadyn-mt[1012]: Mon Jun 27 23:41:53 2016: S:INADYN: Co.....Hint: Some lines were ellipsized, use -l to show in full.
    root@geexbox:~#

    Thank You veey much.

    #11871

    Godrigos
    Participant

    Hi folks, sorry bumping such an old topic. But, to make the story short I did a very stupid thing and lost my compiled package of inadyn-mt. So, I have to do all again, fine. Built openbricks, started the new package and got stuck at a Cross Compilation error. I remember buming into it the last time I compiled inadyn-mt, but can not remember how I got out of it (not sure, but spcifing libs or toolchains, maybe).

    Here is a sahred folder were you can see the error log and the files used to compile. The source code used is here!

    Really sorry to bother you guys, but may you help me get out of this mess. 🙂

    #11873

    Warped Rudi
    Keymaster

    You can try this package…

    #11874

    Godrigos
    Participant

    Nice, it compiles smoothly. I’ll study your fixes and test the new package later this weekend. Thank you very much. Especially for the patience…

    #11875

    Warped Rudi
    Keymaster

    I’ve added the package to our ‘devel’ branch. Let us know if there are any problems with it.

    #11876

    Godrigos
    Participant

    Working like a charm…

    #11877

    Warped Rudi
    Keymaster

    Good. I’ve merge it to our master branch. So the upcoming snapshots will include it as well.

Viewing 12 posts - 31 through 42 (of 42 total)

You must be logged in to reply to this topic.