[ solved ] Howto install it in HDD?

December 8th, 2011

Home Forums GeeXboX for PC [ solved ] Howto install it in HDD?

This topic contains 40 replies, has 8 voices, and was last updated by  tomlohave 2 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 41 total)
  • Author
    Posts
  • #1482

    DOSSTONED
    Member

    Originally, I have tested the method stated in the Documentation area, that works. I added the casper-rw file and add args in the GRUB. But I cannot save my configurations(say, change the font).

    I found out that the file rootfs can be mounted in Fedora, it actually the whole system. After copying those files into geexbox partition with -pr option, and remove rootfs, the vmlinuz said he cannot file the root…

    I just wanna save changes and hope to modify them in another OS(in case the system is down.) Any suggestions?

    btw, how to compile the source? Under Fedora 15

    • This topic was modified 2 years, 7 months ago by  tomlohave.
    #1483

    tomlohave
    Moderator

    x64 or i386 ?
    if i386, replace your initrd by this one : http://download.geexbox.org/releases/extra/initrd
    Now it should work

    compile the source ? the entire geexbox distribution ? see openbricks.org for that.

    #1494

    DOSSTONED
    Member

    arch = i386
    nope…

    it is still not working. Error indicates current root is not in splashfs format.

    #1495

    tomlohave
    Moderator

    try this latest iso :http://download.geexbox.org/releases/extra/i386/latest-iso-devel.iso
    No time to build an x86_64 one

    #1711

    zzzz88
    Member

    I met the same problems and therefore I make a patch for init file in initrd.

    1. put all geexbox files into /GEEXBOX directory including rootfs
    2. add grub menu
    title GEEXBOX
    root (hd0,1)
    kernel /GEEXBOX/vmlinuz vga=789 persistent loglevel=3 live-path=GEEXBOX root=/dev/sda2
    initrd /GEEXBOX/initrd.xz

    “live-path” is my new parameter in init file.

    3. patch init in initrd

    diff -uN mnt2/init mnt/init
    — mnt2/init 2011-09-16 01:32:12.000000000 +0800
    +++ mnt/init 2011-11-23 15:27:34.954000159 +0800
    @@ -31,6 +31,9 @@
    data=*)
    DATA=”${arg#data=}”
    ;;
    + live-path=*)
    + LIVE_PATH=”${arg#live-path=}”
    + ;;
    init=*)
    INIT=”${arg#init=}”
    ;;
    @@ -50,8 +53,8 @@
    # try to mount the rootfs specified in cmdline…
    if [ -n "$ROOT" ]; then
    dbg_echo -n “Trying root=$ROOT as requested…”
    - if mount -o ro $ROOT /mnt >/dev/null 2>&1; then
    - if mount -t squashfs /mnt/rootfs /squashfs >/dev/null 2>&1; then
    + if mount -o rw $ROOT /mnt >/dev/null 2>&1; then
    + if mount -t squashfs /mnt/$LIVE_PATH/rootfs /squashfs >/dev/null 2>&1; then
    dbg_echo “found.”
    else
    dbg_echo “failed, cannot mount squashfs.”
    @@ -86,7 +89,7 @@
    continue
    fi
    fi
    - if mount -t squashfs /mnt/rootfs /squashfs >/dev/null 2>&1; then
    + if mount -t squashfs /mnt/$LIVE_PATH/rootfs /squashfs >/dev/null 2>&1; then
    dbg_echo “found.”
    FOUND_ROOTFS=yes
    break
    @@ -110,7 +113,7 @@

    # setup aufs
    if [ "$PERSISTENT" = yes ]; then
    - DATA=/mnt/casper-rw
    + DATA=/mnt/$LIVE_PATH/casper-rw
    PERSISTENT_OPT=”-o loop -t ext2″
    [ ! -f "$DATA" ] && unset DATA && unset PERSISTENT_OPT
    fi

    • This reply was modified 2 years, 8 months ago by  zzzz88.
    #1717

    tomlohave
    Moderator

    you can test this one : http://download.geexbox.org/releases/extra/i386/latest-iso-devel.iso
    just add root=your_disk persistent=/directory_to_casper_rw/casper-rw

    #1983

    ridgeline
    Member

    Hello,
    I’ve the same/similar problem: I can start GEEXBOX from HDD without any error, but I can’t store any changes.
    File system: ext4
    Grub2 bootloader
    rootfs in / (sda1)
    casper-rw in / (sda1)
    initrd (558,1kb-version) & vmlinuz in /GEEXBOX/

    menuentry ‘Gee 2.0a’{
    set root=(hd0,1)
    linux /GEEXBOX/vmlinuz root=/dev/sda1 quiet splash
    initrd /GEEXBOX/initrd
    }

    I’ve tied the parameter persistent-/casper-rw, but I get error messages like this:
    linux /GEEXBOX/vmlinuz root=/dev/sda1 persistent=/casper-rw quiet splash
    Error message
    aufs test_br: 179 ….
    mount /newroot failed

    The file casper-rw: owner root rw; group root readonly; others readonly

    Thanks for help

    Eduard

    #1984

    tomlohave
    Moderator

    regular i386-iso ?
    initrd from http://download.geexbox.org/releases/extra/initrd ?
    If you really want to install it to hdd (not with rootfs etc) try this iso : http://download.geexbox.org/releases/extra/i386/latest-iso-devel.iso

    • This reply was modified 2 years, 7 months ago by  tomlohave.
    #1992

    ridgeline
    Member

    its regular I386-iso (Ubuntu 11.04) 32-bit system in parallel ; HDD = TS32GSSD25S-M:
    I’ve installed the “latest-iso-devel.iso” and initrd
    I’ve copied the “rootfs” file into /

    menuentry ‘Gee 2.0c’{
    set root=(hd0,1)
    linux /GEEXBOX/vmlinuz root=/dev/sda1 quiet splash
    initrd /GEEXBOX/initrd
    }
    without persistent parameter I get following messages during startup:
    could not open framebuffer: No such file or directory
    - EXT3-fs (sda1): error: couldn’t mount because of unsupported optional features (240)
    - EXT2-fs (sda1): error: couldn’t mount because of unsupported optional features (240)
    XBOX starts, but no change permanent

    menuentry ‘Gee 2.0d persistent’{
    set root=(hd0,1)
    linux /GEEXBOX/vmlinuz root=/dev/sda1 persistent=/GEEXBOX/casper-rw quiet splash
    initrd /GEEXBOX/initrd
    }
    with persistent I get following:
    - could not open framebuffer: No such file or directory
    - EXT3-fs (sda1): error: couldn’t mount because of unsupported optional features (240)
    - EXT2-fs (sda1): error: couldn’t mount because of unsupported optional features (240)
    - aufs test_br:173:mount write permission …
    - mount: mounting none on /newroot failed: invalid argument …
    - Cannot mount aufs, dropping to shell
    - BusyBox v1.19.2

    #1993

    tomlohave
    Moderator

    fstype for your disk ?
    under ubuntu, what says
    cat /proc/mounts

    #1994

    ridgeline
    Member

    cat /proc/mounts
    Result:
    rootfs / rootfs rw 0 0
    none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
    none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
    none /dev devtmpfs rw,relatime,size=893524k,nr_inodes=215433,mode=755 0 0
    none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
    fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
    /dev/disk/by-uuid/a4488ca6-aa7d-44e8-92c8-96a3e5fe8610 / ext4 rw,relatime,errors=remount-ro,barrier=1,data=ordered 0 0
    none /sys/kernel/debug debugfs rw,relatime 0 0
    none /sys/kernel/security securityfs rw,relatime 0 0
    none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
    none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
    none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
    binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
    gvfs-fuse-daemon /home/loewe/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0

    Thanks for the help

    #1995

    tomlohave
    Moderator

    i didn’t carefully read your post, geexbox boot without persistent so add “rw” should work
    all my files are in /geexbox : rootfs, initrd, vmlinuz and casper-rw

    my grub.cfg :

    menuentry “Geexbox” {
    set root=(hd0,1)
    linux /geexbox/vmlinuz root=/dev/sda1 rootfs=/geexbox/rootfs persistent=/geexbox/casper-rw rw
    initrd /geexbox/initrd
    }

    #2018

    ridgeline
    Member

    Thanks @tomlohave,
    you were right; the rw was missing, now it’s working.

    Eduard

    #2300

    akostadinov
    Member

    @tomlohave, thanks much for the information. It was super easy to get geexbox 2 devel running next to geexbox 1 on an existing NTFS partition. I already had geexbox 1 with grub4dos installed through windows installer. So I:
    * created a GEEXBOX2 directry
    * put initrd, vmlinuz, rootfs, casper-rw in c:\GEEXBOX2
    * added an entry in the existing c:\GEEXBOX\boot\menu.lst :
    title Start Geexbox 2
    kernel=/GEEXBOX2/vmlinuz root=/dev/sda1 rootfs=/GEEXBOX2/rootfs persistent=/GEEXBOX2/casper-rw rw boot=
    initrd=/GEEXBOX2/initrd

    It started just fine and casper-rw is used. After one reboot I see settings are kept. But on shutdown and reboots I see umount errors that go too fast to read them. On the next reboot settings are lost, I assume casper-rw becomes corrupted. Any idea how to fix the shutdown process?

    #2301

    craigus
    Member

    Confirmed here also. After more than one reboot, ext2_lookup: deleted inode referenced errors occur and drops to shell and then dies.

Viewing 15 posts - 1 through 15 (of 41 total)

You must be logged in to reply to this topic.

Comments are closed.