HDMI audio issues

September 23rd, 2012

Home Forums GeeXboX for PC HDMI audio issues

Tagged: ,

This topic contains 8 replies, has 6 voices, and was last updated by  beginner 1 year, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4598

    thorlax402
    Member

    Hello,

    I am having some trouble getting audio configured through HDMI on a fresh installation of GeeXbox. I have read through a number of forum posts with similar issues, but have had some trouble deciphering the solution. Would someone mind explaining how I would go about figuring out the audio settings my machine would require?

     

    Thank you!

    #4600

    josch.hh
    Member

    Login into a terminal on your geexbox machine (for example use a telnet client of your choice and login with usename: root and passwd: root).

    runing “aplay -l” and the output should be similar to this:

    # aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: VT1708S Analog [VT1708S Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: VT1708S Digital [VT1708S Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 2: VT1708S HP [VT1708S HP]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0

    As you can see the HDMI device is “card 0, device 3″

    So enter in your XBMC audio settings the user defined value “hw:0,3″ (for this case).

    I know it is not nice but will be much better in the version of XBMC (i.e. Frodo).

    • This reply was modified 2 years ago by  josch.hh.
    #4604

    thorlax402
    Member

    Thank you for the quick reply. My NVidia card is labeled as card 1, device 3. I input the appropriate value for this as specified with no effect (though I did not receive audio settings errors like I did for some of the other options presented in the drop-down for audio settings). Is there something else I might try to get this working? Is it possible I don’t have correct drivers?

    #4613

    josch.hh
    Member

    Did you check if your machine is able to send sound via HDMI on other OS’s?

    Please provide some details about your hardware and maybe some logs?
    Is the HDMI out of your PC conetect to a TV or an AVR?

     

    • This reply was modified 2 years ago by  josch.hh.
    #4615

    thorlax402
    Member

    Connected to a TV. Yesterday morning, before installing GeeXbox, I was running XBMC as an application on the same machine with Windows instead of GeeXbox. Sound was working just fine, and I have an NVidia graphics card in use.

    I would be happy to provide logs, but could you tell me where I could find them?

     

    Thank you.

    #4616

    tomlohave
    Moderator

    please install xf86-video-nvidia first

    #4907

    TommySharp
    Member

    I’m having the exact same issue and have already installed the nvidia drivers….

     

    #6027

    Miklos
    Member

    I have same issue with a Rev B1 board

     

    asound / audio

     

    http://paste2.org/p/3058195

    #6028

    beginner
    Member

    ALSA_CARD=”0″

    SOUNDCARD_MODE=”hdmi”

    SOUNDCARD_PT_MODE=”ac3″

    AC97_SPSA=”1″

    CHANNELS=”2″

    SBL_AUDIGY=”1″

     

     

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.