Geexbox for Efika MX Smarttop

Home Forums GeeXboX on ARM SoCs Geexbox for Efika MX Smarttop

This topic contains 11 replies, has 2 voices, and was last updated by  Razora 5 years, 9 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #3310

    Razora
    Member

    Hey guys,

    I got a Efika MX Smarttop a few days ago. Now, I’m looking for a media-center-software for it and I found Geexbox. But I have a problem: I’m very very new to the arm-architecture and embedded-systems. So, Is there a good step-by-step tutorial for the installation of geexbox on the Efika MX Smarttop?

    Greetings
    René

    #3311

    tomlohave
    Keymaster

    hi,
    your achitecture seems to be supported, there is aleady a xf86-video-imx5 package for your board
    Now you need to build your own binaries …

    first :
    hg clone hg.openbricks.org/openbricks
    make xconfig

    here choose your architecture/platform/packages you want
    save and exit

    make ( take a big coffee ….)

    documentation is here : http://www.openbricks.org/docs/openbricks-manual.pdf
    Good luck
    Now if you want a better support, subscribe to devel mailing list : http://www.openbricks.org/mailing-lists/

    #3316

    Razora
    Member

    Hey,

    thank you for your help. I tried your solution, but I got following error: “Can’t get libnfsidmap sources : http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/libnfsidmap-0.24.tar.gz Try later !!”
    Will it realy work “later” or is this another problem and it won’t work tomorrow or in two days?

    #3317

    tomlohave
    Keymaster

    not all sources are in our server, that’s the case for libnfsidmap, try later or change file packages/libnfsidmap/meta (if you find another source)

    #3318

    tomlohave
    Keymaster

    fixed now, i have uploaded all sources to our server (7 missing but shouldn’t harm your build)
    please do :
    hg pull -u
    make

    #3319

    Razora
    Member

    Thank you for the upload, but I could solve the problem on my own before.
    Now I have a new error. mxc_ipu_hl_lib.c:44:28: fatal error: linux/videodev.h: No such file or directory
    Do have any solution for this problem. (If it’s necessary: I’m using Ubuntu 11.10 at the moment)

    Greetings
    René

    #3320

    tomlohave
    Keymaster

    depending on your kernel build, but for recent kernel, it’s not videodev.h but videodev2.h
    which package ? imx5-lib or imx6-lib ?
    in imx6-lib you ve got patches to remove this, if you try to build imx5-lib, do the same (look in packages/imx6-lib/patches/ )
    As already said too, post this in devel mailing-list , Ben can answer more easily than me, i don’t have such board 😉

    #3321

    Razora
    Member

    Ok, it seems to be a problem with my kernel. I’m using 3.0.0-16.28. I think I will try to install it seperatly. I will write back, if I found a solution.

    #3322

    tomlohave
    Keymaster

    hum you can’t … (and it’s not a problem with your installed kernel )
    kernel is built before this lib … and for your target arch it seems it’s version 3.1.0-1001.1
    so you need to fix imx5-lib with a patch … (or try to update it ? )

    #3324

    Razora
    Member

    Thanky very very much for your help. But now, I don’t understand anything 🙂
    In imx6-lib I found the two .diff-files. I think I have to apply these patches to the imx5-package. But I don’t know how to do it. Can you give me a hint which commandos I have to use to apply the patch?

    #3327

    tomlohave
    Keymaster

    copy directory patches in imx6-lib to imx5-lib but (…) i doubt it would work. not the same libs. You’ve got an example what to do but you need to prepare the patch by yourself ….
    do

    ./scripts/clean imx5-lib
    ./scripts/unpack imx5-lib
    in your build directory search the difference made between imx5-lib and imx6-lib (look at patches) , modify source file(s), when you think it’s ready
    ./scripts/build imx5-lib
    if no complain, prepare a patch and submit it to devel list for inclusion

    else wait for a dev to fix your problem –> report this to devel mailing list
    (not me, i’m on vacation in 2 hours, sorry)

    #3328

    Razora
    Member

    I will try it in an hour. Thank you for your help.
    I wrote a report to the devel mailing list and I’m now waiting for a response.

    Thank you for your help and I wish you happy hollidays.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.