Frodo on Panda

March 12th, 2013

Home Forums GeeXboX on ARM SoCs Frodo on Panda

This topic contains 35 replies, has 5 voices, and was last updated by  panz 1 year, 2 months ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #6127

    as78
    Member

    works now placing openbricks in a folder with no space in the path name.

    #6128

    as78
    Member

    too early saying it works :-)

     

    Can’t get opkg-utils sources, falling back to repository
    scripts/get: 125: scripts/get: git: not found
    make: *** [silentoldconfig] Error 127

    #6129

    tomlohave
    Moderator

    install git

    #6130

    as78
    Member

    ok, installed git, now it’s compiling. I get several warnings, let’s see :-)

    #6163

    as78
    Member

    all right, it ends with an

    –2013-04-01 19:33:32–  http://sources.openbricks.org/devel/libdca-0.5.tar.bz2
    Resolving sources.openbricks.org (sources.openbricks.org)… 67.203.12.194
    Connecting to sources.openbricks.org (sources.openbricks.org)|67.203.12.194|:80… connected.
    HTTP request sent, awaiting response… 404 Not Found
    2013-04-01 19:33:32 ERROR 404: Not Found.

    Can’t get libdca sources, falling back to repository
    scripts/get: 119: scripts/get: svn: not found
    make: *** [rootfs] Error 127

    What can I do? And once I fix this, is there a chance to continue there without starting from zero?

    #6165

    tomlohave
    Moderator

    yes, sure

    install svn ;-)

     

    #6184

    as78
    Member

    believe it or not, it compiled and left the image :-) I’ll test during the week and provide the results.

    In a short test, airplay seemed not to be properly announced.. I came across a patch http://trac.xbmc.org/attachment/ticket/13935/airplay.diff, I might test it and see if it works.

    #6185

    tomlohave
    Moderator

    ok, I have done some tests

    – nfs is broken one more time under xbmc, I can’t play videos over nfs

    – there is a problem with sound, I can’t dicrease it, no effect, seems there is a problem with config (AE ? )

    – another problem with sound playing live tv using paplayer ….

    #6194

    as78
    Member

    Audio via HDMI gave me horrible distortion. I was painfully taught not to test audio with volume high, there is still ringing in my ears :-)

    The analog audio of the TWL6040 is also not working.

    But audio per USB works perfectly, I tested several DACs, sounds good.

    Do you happen to know how IPv6 can be disabled?

    #6196

    tomlohave
    Moderator

    yes we have problem with sound, on mine hdmi audio works fine.

    for ipv6, blacklist module ?

    #6240

    as78
    Member

    I thought deactivating IPv6 might help, since it solves issues on a mac connecting to XBMC via airplay.

    Actually I could not find a kernel module that sounds like IPv6 – is there one implemented?

    #6243

    as78
    Member

    I made a diff between the source codes of the actual xbmc AirPlayServer.cpp and the one of geexbox and see that a lot differs.. I would love to see airplay working.

    Now since the likelihood for failing trying to patch is almost 100% for me (told already I’m a h/w guy, did I :-), I am getting lost with new headers, also not knowing what differs due to pandaboard/openbrick implementation), is it possible you could patch it? I am pretty much lost, but I hope that the changes implemented meanwhile might fix airplay.

     

    #6249

    tomlohave
    Moderator

    Will try

    #6342

    lenik
    Member

    Hi Tom,

    Thank you a lot for your efforts!

    hg clone http://hg.openbricks.org/openbricks
    cd openbricks
    ./scripts/loadcfg geexbox-xbmc-omap4-pandaboard
    make

    did exactly this, and build went along for a while, until it tried to build the compiler using the following command:

    /home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/bin/host-gcc -O2 -Wall -pipe -I/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/include -DIN_GCC -DCROSS_DIRECTORY_STRUCTURE -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat -DHAVE_CONFIG_H -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -lm -o cc1 c-lang.o c-family/stub-objc.o attribs.o c-errors.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-objc-common.o c-parser.o tree-mudflap.o c-family/c-common.o c-family/c-cppbuiltin.o c-family/c-dump.o c-family/c-format.o c-family/c-gimplify.o c-family/c-lex.o c-family/c-omp.o c-family/c-opts.o c-family/c-pch.o c-family/c-ppoutput.o c-family/c-pragma.o c-family/c-pretty-print.o c-family/c-semantics.o c-family/c-ada-spec.o arm-c.o default-c.o \
    cc1-checksum.o main.o libbackend.a libcommon-target.a libcommon.a ../libcpp/libcpp.a ../libdecnumber/libdecnumber.a libcommon.a ../libcpp/libcpp.a ../libiberty/libiberty.a ../libdecnumber/libdecnumber.a -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -lcloog-isl -lisl -lstdc++ -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -lppl_c -lppl -lgmpxx -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -L/home/lenik/openbricks/build/build.pandaboard.eglibc/toolchain/lib -lmpc -lmpfr -lgmp -rdynamic -ldl -L../zlib -lz

    that failed because of some missing c++ libraries, that are not found (maybe) because we’re using ‘host-cc’ to build what seems to be a c++ program. I have copied the exactly command and replaced ‘host-cc’ with ‘host-c++’ to fix the issue. That worked, but when I restart the make, it tries to issue the original command again (to fail again), and I could not figure out which of the numerous Makefiles I have to change to fix this.

    Could you please advise, where this ‘host-cc’ comes from the where it should be changed for successful compilation? Do you use Linaro toolchain for your builds or something else?

    #6345

    tomlohave
    Moderator

    hum

    do you have gcc and g++ installed on your machine ?

    host-cc is only a symling to your installed gcc

    (note the host …)

    What is your distro ?

     

Viewing 15 posts - 16 through 30 (of 36 total)

You must be logged in to reply to this topic.

Comments are closed.