Fresh install problems

Home Forums GeeXboX on ARM SoCs Fresh install problems

This topic contains 23 replies, has 3 voices, and was last updated by  tomlohave 1 month, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #11708

    skelos
    Participant

    Hello,
    in order to solve definitively probles about Sickrage I did a fresh install in Cubox-i 4×4.

    I installed python-sickrage package and installations had success.

    Now If I check sickrage on web http://MYADDRESS:8081/ I see the message “Tempo per la connessione esaurito” it sounds like “Connection timeout” or “Connection time expired”.

    I checked status service :`
    root@geexbox /root$ systemctl status sickrage
    ● sickrage.service – SickBeard Daemon
    Loaded: loaded (/usr/lib/systemd/system/sickrage.service; disabled; vendor preset: enabled)
    Active: active (running) since Thu 1989-01-26 18:24:06 GMT; 28 years 3 months ago
    Process: 324 ExecStart=/usr/bin/python /opt/sickbeard/SickBeard.py -q –daemon –nolaunch –datadir=/opt/sickbeard (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/sickrage.service
    └─1289 /usr/bin/python /opt/sickbeard/SickBeard.py -q –daemon –nolaunch –datadir=/opt/sickbeard`

    So, how I can access to sickrage web?

    Other proble concerning USB DVB-T receiver. When I try in Tvheadend Italian network I had all result FAILS.

    Hardware work fine : If I insert old SD woth old installation I see all channels fine.

    lsusb command shows
    Bus 001 Device 002: ID 048d:9135 Integrated Technology Express, Inc. Zolid Mini DVB-T Stick
    and this is good.

    In Tvheadend website I enabled receiver, select Italian as unique network but scan fails.

    Any Idea?

    #11710

    tomlohave
    Keymaster

    Hello Skelos

    Let’s try to solve your problems one by one

    first, you have a problem with the time on your machine :

    Active: active (running) since Thu 1989-01-26 18:24:06 GMT; 28 years 3 months ago

    so, you can use something like :
    ntpd -d -n -q -p ntp.obspm.fr
    to solve this first problem then reboot

    Then, once restarted what returns :

    opkg list-installed | grep sick

    • This reply was modified 2 months, 3 weeks ago by  tomlohave.
    #11711

    tomlohave
    Keymaster

    I justed test the install of python-sickrage (i386) on a virtual machine and no problem, it works out of the box.
    I have a regular install of this package on my cuboxi, and it works correctly too.

    #11728

    skelos
    Participant

    I didn’t care of service date. date command is ok:

    root@geexbox:~# date
    Mon May  8 14:25:44 BST 2017

    Now this is I installed about sick:

    root@geexbox:~# opkg list-installed | grep sick
    python-sickrage - v2017.02.2-1-1

    I got it using “opkg install python-sickrage” command….

    After reboot date is wrong again…

    root@geexbox:~# systemctl status sickrage
        sickrage.service - SickBeard Daemon
       Loaded: loaded (/usr/lib/systemd/system/sickrage.service; disabled; vendor pr
    eset: enabled)
       Active: active (running) since Thu 1989-02-02 20:47:35 GMT; 28 years 3 months
     ago
      Process: 311 ExecStart=/usr/bin/python /opt/sickbeard/SickBeard.py -q --daemon
     --nolaunch --datadir=/opt/sickbeard (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/sickrage.service
               ÔööÔöÇ1231 /usr/bin/python /opt/sickbeard/SickBeard.py -q --daemon --
    n...
    • This reply was modified 2 months, 2 weeks ago by  skelos.
    #11731

    tomlohave
    Keymaster

    ok , you have the good version.

    Please, fix the date with ntp then (do not reboot)
    restart sickrage service.

    Stupid question, but you used the good ip to join the server ?

    some logs can help too :

    cat /opt/sickrage/Logs/sickrage.log

    #11732

    skelos
    Participant

    Yes, i’m sure this is good IP address.
    My Cubox-i is in my DMZ zone and is the unique machine where I am redirected accessting from my home network from intenet using free dns.
    And anso under /media I see exactly what I expexct. ^_^

    For ntp I let you know but why It is so important?

    • This reply was modified 2 months, 2 weeks ago by  skelos.
    #11734

    skelos
    Participant

    Restarting only Sickrage service and not whole cubox time is ok. But Sickrage doesn’t works.

    How I can run ntp command one time each cubox start up?

    #11735

    Warped Rudi
    Keymaster

    You don’t have to. The ntp client will run automatically. However, it is possible that the real time clock in you box is in a bogus state and that you get a strange time readings inside the window between power up and the ntp request. To fix that, make sure that the time is correct and then run:

    hwclock -w

    If the battery is O.K., the time issue should be gone. BTW, an error message regarding the RTC might be seen using either dmesg or journalctl

    #11736

    tomlohave
    Keymaster

    small question : how do you access your device ? I mean is it from inside your lan (with a pc inside your DMZ, did you test ?) or from internet using your ISP box ?
    If it’s the second case, maybe it’s a problem with your box, ie redirect traffic from port 8081 to your_static_ip:8081

    #11745

    skelos
    Participant

    I test this comand:
    root@geexbox:~# journalctl | grep RTC
    Feb 02 20:47:16 geexbox systemd[1]: Failed to start Synchronize System Clock With RTC.

    but this is very old : Feb 02…. so this problem may be solved (how really I don’t know).

    #11748

    Warped Rudi
    Keymaster

    Does hwclock (without any parameter) show the correct time (UTC zone)?

    • This reply was modified 2 months, 2 weeks ago by  Warped Rudi.
    #11812

    skelos
    Participant

    ok,I think to be solved time problem:

    root@geexbox:~# systemctl status sickrage
        sickrage.service - SickBeard Daemon
       Loaded: loaded (/usr/lib/systemd/system/sickrage.service; disabled; vendor pr
    eset: enabled)
       Active: active (running) since Mon 2017-05-22 20:43:02 BST; 3 days ago
      Process: 304 ExecStart=/usr/bin/python /opt/sickbeard/SickBeard.py -q --daemon
     --nolaunch --datadir=/opt/sickbeard (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/sickrage.service
               ÔööÔöÇ1255 /usr/bin/python /opt/sickbeard/SickBeard.py -q --daemon --
    n...

    now, we can back to main issue: sickrage website goes in timeout.

    I refresh your memory getting from first post:

      If I check sickrage on web http://MYADDRESS:8081/ I see the message “Tempo per la connessione esaurito” it sounds like “Connection timeout” or “Connection time expired”.

    So, how I can do for start sickrage website?

    #11813

    tomlohave
    Keymaster

    ok,
    now as aready requested, did you test in your real lan (not from the internet) ?

    and what returns :
    netstat -tulpn ?

    Funny, I have exactly the same problem as yours about the time …

    systemctl status sickrage
    ● sickrage.service – SickBeard Daemon
    Loaded: loaded (/usr/lib/systemd/system/sickrage.service; disabled; vendor preset: enabled)
    Active: active (running) since Thu 1970-01-01 01:00:25 BST; 47 years 4 months ago
    Process: 425 ExecStart=/usr/bin/python /opt/sickbeard/SickBeard.py –daemon –nolaunch –datadir=/opt/sickbeard (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/sickrage.service
    └─5170 /usr/bin/python /opt/sickbeard/SickBeard.py –daemon –nolaunch –datadir=/opt/sickbeard

    #11814

    tomlohave
    Keymaster

    I forget to say that you should have a line like that :

    tcp 0 0 0.0.0.0:8081 0.0.0.0:* LISTEN 5170/python

    #11815

    skelos
    Participant

    I telnet on my DMZ pc so, I hope this is sufficient for consider command runs from my internal lan.

    This is a partial result:

    root@geexbox:~# netstat -tulpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State   PID/Program name
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN  20569/kodi.bin
    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN  1081/lighttpd
    tcp        0      0 0.0.0.0:8081            0.0.0.0:*               LISTEN  1273/python

    etc, etc…
    So last line is what we are expecting, right?

Viewing 15 posts - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.