1st gen Cubox won't boot

Home Forums GeeXboX on ARM SoCs 1st gen Cubox won't boot

This topic contains 8 replies, has 2 voices, and was last updated by  Warped Rudi 4 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11847

    Eun
    Participant

    I am unable to boot the image any instructions?

    I used the make-sdcard tool

    #11848

    Warped Rudi
    Keymaster

    Usually this link should give you a hint. Note that on newer systems, the sd card device is named ‘mmcblkX’, not sdX. Be sure to specify the device, not a partition. Also it might be helpful to attach a (USB-)serial console to your box to see where the boot process hangs.

    #11853

    Eun
    Participant

    Thanks for the answer and tips, but still wasn’t able to boot it up.

    Here is the serial output:

    
    CuBox
     ** LOADER **
    
    U-Boot 2009.08 (Jan 15 2012 - 00:43:32) Marvell version: 5.4.4 NQ
    
    BootROM:
           Version on chip: 2.33
           Status: OK
           Retries #: 0
    Board: CuBox
    SoC:   88AP510 (A1)
    CPU:   Marvell Sheeva (Rev 5)
           CPU @ 800Mhz, L2 @ 400Mhz
           DDR3 @ 400Mhz, TClock @ 166Mhz
    PEX 0: interface detected no Link.
    PEX 1: interface detected no Link.
    DRAM:   1 GB
           CS 0: base 0x00000000 size 512 MB
           CS 1: base 0x20000000 size 512 MB
           Addresses 12M - 0M are saved for the U-Boot usage.
    SF: Detected M25P32 with page size 64 kB, total  4 MB
    
    Streaming disabled 
    L2 Cache Prefetch disabled
    L2 Cache ECC disabled
    Modifying CPU/CORE/DDR power rails to 1.0(-2.5%) / 1.0(-5%) / 1.5(-5%)
    USB 0: Host Mode
    USB 1: Host Mode
    Setting VPU power OFF.
    Setting GPU power ON.
    MMC:   MV_SDHCI: 0, MV_SDHCI: 1
    Net:   egiga0 [PRIME]
    Hit any key to stop autoboot:  0 
    ===> Executing ext2load usb 0:0 0x02000000 /boot.scr
    (Re)start USB...
    USB:   Register 10011 NbrPorts 1
    USB EHCI 1.00
    scanning bus for devices... 1 USB Device(s) found
    Waiting for storage device(s) to settle before scanning...
           scanning bus for storage devices... 0 Storage Device(s) found
    Loading file "/boot.scr" from usb device 0
    ** Bad partition - usb 0:0 **
    ===> Executing ext2load usb 1:0 0x02000000 /boot.scr
    Loading file "/boot.scr" from usb device 1
    ** Bad partition - usb 1:0 **
    ===> Executing fatload usb 0:0 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:0 for fatload **
    ===> Executing fatload usb 1:0 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:0 for fatload **
    ===> Executing ext2load usb 0:0 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from usb device 0
    ** Bad partition - usb 0:0 **
    ===> Executing ext2load usb 1:0 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from usb device 1
    ** Bad partition - usb 1:0 **
    ===> Executing fatload usb 0:0 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:0 for fatload **
    ===> Executing fatload usb 1:0 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:0 for fatload **
    ===> Executing ext2load usb 0:1 0x02000000 /boot.scr
    ** Bad partition 1 **
    ===> Executing ext2load usb 1:1 0x02000000 /boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext2load usb 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing ext2load usb 1:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext2load mmc 0:0 0x02000000 /boot.scr
    Device: MV_SDHCI
    Manufacturer ID: 41
    OEM: 3432
    Name: SD4GB 
    Tran Speed: 25000000
    Rd Block Len: 512
    SD version 2.0
    High Capacity: Yes
    Capacity: 3980394496
    Bus Width: 4-bit
    Loading file "/boot.scr" from mmc device 0
    Failed to mount ext2 filesystem...
    ** Bad ext2 partition or disk - mmc 0:0 **
    ===> Executing fatload mmc 0:0 0x02000000 /boot.scr
    ** Partition 0 not valid on device 0 **
    
    ** Unable to use mmc 0:0 for fatload **
    ===> Executing ext2load mmc 0:0 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from mmc device 0
    Failed to mount ext2 filesystem...
    ** Bad ext2 partition or disk - mmc 0:0 **
    ===> Executing fatload mmc 0:0 0x02000000 /boot/boot.scr
    ** Partition 0 not valid on device 0 **
    
    ** Unable to use mmc 0:0 for fatload **
    ===> Executing ext2load mmc 0:1 0x02000000 /boot.scr
    Loading file "/boot.scr" from mmc device 0:1 (mmcda1)
    ** File not found /boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot.scr
    reading /boot.scr
    
    ** Unable to read "/boot.scr" from mmc 0:1 **
    ===> Executing ext2load mmc 0:1 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from mmc device 0:1 (mmcda1)
    ** File not found /boot/boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot/boot.scr
    reading /boot/boot.scr
    
    ** Unable to read "/boot/boot.scr" from mmc 0:1 **
    ===> Executing ext2load ide 0:0 0x02000000 /boot.scr
    
    Reset IDE: 
    Marvell Serial ATA Adapter
    Integrated Sata device found
    
    Loading file "/boot.scr" from ide device 0
    ** Bad partition - ide 0:0 **
    ===> Executing fatload ide 0:0 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:0 for fatload **
    ===> Executing ext2load ide 0:0 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from ide device 0
    ** Bad partition - ide 0:0 **
    ===> Executing fatload ide 0:0 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:0 for fatload **
    ===> Executing ext2load ide 0:1 0x02000000 /boot.scr
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    ===> Executing ext2load ide 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    Using egiga0 device
    TFTP from server 192.168.15.100; our IP address is 192.168.15.223
    Filename 'boot.scr'.
    Load address: 0x2000000
    Loading: *
    
    #11854

    Warped Rudi
    Keymaster

    Ahh, I see:

    U-Boot 2009.08 (Jan 15 2012 - 00:43:32) Marvell version: 5.4.4 NQ

    Our boot script expects something like:

    U-Boot 2009.08 (Sep 20 2012 - 02:30:22) Marvell version: 5.4.4 NQ SR1

    Note the ‘SR1‘ at the end. That is important. It’s a bit tricky to update. I’ll give some instructions tomorrow…

    #11855

    Warped Rudi
    Keymaster

    O.K. I think we’ll try the “unbrick method”…

    Assuming that you have a PC running Linux (we use Ubuntu), do the following:

    – Make sure the the tools “sx” and “minicom” are present on your PC. If not
    install them by: sudo apt-get install minicom lrzsz

    – Copy the file /boot/u-boot-cubox_hynix_cubox_1GB_uart.bin from the
    SD card to your PC. Then re-insert the SD card into the CuBox.

    – Connect the USB console cable and determine it’s device name (something like
    /dev/ttyUSB0, you already know it as you sent a u-boot log before)

    – Create a shell script with the following content on your PC:

    #! /bin/sh
    
    TTY="/dev/<your_ttyUSB>"
    BIN="u-boot-cubox_hynix_cubox_1GB_uart.bin"
    
    stty -F $TTY 115200 && sx -vv $BIN < $TTY > $TTY && minicom -o -D $TTY

    – Below the eSATA connector on the CuBox there is a small hole. Behind it is a little
    button that can be accessed by using a paper clip or a very small screw driver. You
    can hear it clicking when pressed.

    – Now you have to be quick: Start the script. Then press the button and apply power
    to the CuBox while the button is down. You should now see a block/byte counter
    running. If you get a bunch of error messages instead, just re-try. You may need several
    attempts.

    – Then a terminal should open and after a lot of messages you will get a Geexbox
    prompt. Login as ‘root’ / ‘root’ and let it settle for a while.

    – Then, on the Geexbox prompt, enter:

    dd if=/boot/u-boot-cubox_hynix_cubox_unified_spi.bin of=/dev/mtdblock0 conv=fsync
    

    This will take a while and actually writes a new copy of u-boot to the internal flash.
    After that, Geexbox should boot normally.

    #11856

    Eun
    Participant

    Hi, thanks for the answer

    Unfortunately GeexBox does not load, I verified that the correct uboot version was loaded.
    Got another idea? (I also cleared the envrionment with resetenv)

    Log:

    
    
     ** LOADER **
    
    U-Boot 2009.08 (Jun 21 2017 - 22:47:34) Marvell version: 5.4.4 NQ SR1
    
    BootROM:
           Version on chip: 2.33
           Status: OK
           Retries #: 0
    Board: CuBox
    SoC:   88AP510 (A1)
    CPU:   Marvell Sheeva (Rev 5)
           CPU @ 800Mhz, L2 @ 400Mhz
           DDR3 @ 400Mhz, TClock @ 166Mhz
    PEX 0: interface detected no Link.
    PEX 1: interface detected no Link.
    DRAM:   1 GB
           CS 0: base 0x00000000 size 512 MB
           CS 1: base 0x20000000 size 512 MB
           Addresses 60M - 0M are saved for the U-Boot usage.
    SF: Detected M25P32 with page size 64 kB, total  4 MB
    *** Warning - bad CRC, using default environment
    
    Streaming disabled 
    L2 Cache Prefetch disabled
    L2 Cache ECC disabled
    Modifying CPU/CORE/DDR power rails to 1.0(+2.5%) / 1.0(-5%) / 1.5(-5%)
    USB 0: Host Mode
    USB 1: Host Mode
    Setting VPU power OFF.
    Setting GPU power ON.
    MMC:   MV_SDHCI: 0, MV_SDHCI: 1
    Net:   egiga0 [PRIME]
    Hit any key to stop autoboot:  0 
    ===> Executing ext4load usb 0:1 0x02000000 /boot.scr
    (Re)start USB...
    USB:   Register 10011 NbrPorts 1
    USB EHCI 1.00
    scanning bus for devices... 1 USB Device(s) found
    Waiting for storage device(s) to settle before scanning...
           scanning bus for storage devices... 0 Storage Device(s) found
    ** Bad partition 1 **
    ===> Executing ext4load usb 1:1 0x02000000 /boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext4load usb 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing ext4load usb 1:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext4load usb 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing ext4load usb 1:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload usb 0:2 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:2 for fatload **
    ===> Executing fatload usb 1:2 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:2 for fatload **
    ===> Executing ext4load usb 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing ext4load usb 1:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload usb 0:2 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:2 for fatload **
    ===> Executing fatload usb 1:2 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:2 for fatload **
    ===> Executing ext4load mmc 0:1 0x02000000 /boot.scr
    Device: MV_SDHCI
    Manufacturer ID: 41
    OEM: 3432
    Name: SD4GB 
    Tran Speed: 25000000
    Rd Block Len: 512
    SD version 2.0
    High Capacity: Yes
    Capacity: 3980394496
    Bus Width: 4-bit
    Loading file "/boot.scr" from mmc device 0:1 mmcda1
    ** File not found /boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot.scr
    reading /boot.scr
    
    ** Unable to read "/boot.scr" from mmc 0:1 **
    ===> Executing ext4load mmc 0:1 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from mmc device 0:1 mmcda1
    ** File not found /boot/boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot/boot.scr
    reading /boot/boot.scr
    
    ** Unable to read "/boot/boot.scr" from mmc 0:1 **
    ===> Executing ext4load mmc 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload mmc 0:2 0x02000000 /boot.scr
    ** Partition 2 not valid on device 0 **
    
    ** Unable to use mmc 0:2 for fatload **
    ===> Executing ext4load mmc 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload mmc 0:2 0x02000000 /boot/boot.scr
    ** Partition 2 not valid on device 0 **
    
    ** Unable to use mmc 0:2 for fatload **
    ===> Executing ext4load ide 0:1 0x02000000 /boot.scr
    
    Reset IDE: 
    Marvell Serial ATA Adapter
    Integrated Sata device found
    
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    ===> Executing ext4load ide 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    ===> Executing ext4load ide 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload ide 0:2 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:2 for fatload **
    ===> Executing ext4load ide 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload ide 0:2 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:2 for fatload **
    egiga0 no link
    Using egiga0 device
    TFTP from server 192.168.15.100; our IP address is 192.168.15.223
    Filename 'boot.scr'.
    Load address: 0x2000000
    
    • This reply was modified 4 months, 3 weeks ago by  Eun.
    #11858

    Eun
    Participant

    Thanks for your answer, however geexbox still does not load even with the corret uboot.

    I wonder if there should be a boot partition on the sdcard? Because for me there is none.

    Log:

    
     ** LOADER **
    
    U-Boot 2009.08 (Jun 26 2017 - 02:50:08) Marvell version: 5.4.4 NQ SR1
    
    BootROM:
           Version on chip: 2.33
           Status: OK
           Retries #: 0
    Board: CuBox
    SoC:   88AP510 (A1)
    CPU:   Marvell Sheeva (Rev 5)
           CPU @ 800Mhz, L2 @ 400Mhz
           DDR3 @ 400Mhz, TClock @ 166Mhz
    PEX 0: interface detected no Link.
    PEX 1: interface detected no Link.
    DRAM:   1 GB
           CS 0: base 0x00000000 size 512 MB
           CS 1: base 0x20000000 size 512 MB
           Addresses 60M - 0M are saved for the U-Boot usage.
    SF: Detected M25P32 with page size 64 kB, total  4 MB
    *** Warning - bad CRC, using default environment
    
    Streaming disabled 
    L2 Cache Prefetch disabled
    L2 Cache ECC disabled
    Modifying CPU/CORE/DDR power rails to 1.0(+2.5%) / 1.0(-5%) / 1.5(-5%)
    USB 0: Host Mode
    USB 1: Host Mode
    Setting VPU power OFF.
    Setting GPU power ON.
    MMC:   MV_SDHCI: 0, MV_SDHCI: 1
    Net:   egiga0 [PRIME]
    Hit any key to stop autoboot:  0 
    ===> Executing ext4load usb 0:1 0x02000000 /boot.scr
    (Re)start USB...
    USB:   Register 10011 NbrPorts 1
    USB EHCI 1.00
    scanning bus for devices... 1 USB Device(s) found
    Waiting for storage device(s) to settle before scanning...
           scanning bus for storage devices... 0 Storage Device(s) found
    ** Bad partition 1 **
    ===> Executing ext4load usb 1:1 0x02000000 /boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext4load usb 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing ext4load usb 1:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload usb 0:1 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:1 for fatload **
    ===> Executing fatload usb 1:1 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:1 for fatload **
    ===> Executing ext4load usb 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing ext4load usb 1:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload usb 0:2 0x02000000 /boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:2 for fatload **
    ===> Executing fatload usb 1:2 0x02000000 /boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:2 for fatload **
    ===> Executing ext4load usb 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing ext4load usb 1:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload usb 0:2 0x02000000 /boot/boot.scr
    ** Can't read from device 0 **
    
    ** Unable to use usb 0:2 for fatload **
    ===> Executing fatload usb 1:2 0x02000000 /boot/boot.scr
    ** Can't read from device 1 **
    
    ** Unable to use usb 1:2 for fatload **
    ===> Executing ext4load mmc 0:1 0x02000000 /boot.scr
    Device: MV_SDHCI
    Manufacturer ID: 1b
    OEM: 534d
    Name: 00000 
    Tran Speed: 25000000
    Rd Block Len: 512
    SD version 2.0
    High Capacity: Yes
    Capacity: 3974103040
    Bus Width: 4-bit
    Loading file "/boot.scr" from mmc device 0:1 mmcda1
    ** File not found /boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot.scr
    reading /boot.scr
    
    ** Unable to read "/boot.scr" from mmc 0:1 **
    ===> Executing ext4load mmc 0:1 0x02000000 /boot/boot.scr
    Loading file "/boot/boot.scr" from mmc device 0:1 mmcda1
    ** File not found /boot/boot.scr
    ===> Executing fatload mmc 0:1 0x02000000 /boot/boot.scr
    reading /boot/boot.scr
    
    ** Unable to read "/boot/boot.scr" from mmc 0:1 **
    ===> Executing ext4load mmc 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload mmc 0:2 0x02000000 /boot.scr
    ** Partition 2 not valid on device 0 **
    
    ** Unable to use mmc 0:2 for fatload **
    ===> Executing ext4load mmc 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload mmc 0:2 0x02000000 /boot/boot.scr
    ** Partition 2 not valid on device 0 **
    
    ** Unable to use mmc 0:2 for fatload **
    ===> Executing ext4load ide 0:1 0x02000000 /boot.scr
    
    Reset IDE: 
    Marvell Serial ATA Adapter
    Integrated Sata device found
    
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    ===> Executing ext4load ide 0:1 0x02000000 /boot/boot.scr
    ** Bad partition 1 **
    ===> Executing fatload ide 0:1 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:1 for fatload **
    ===> Executing ext4load ide 0:2 0x02000000 /boot.scr
    ** Bad partition 2 **
    ===> Executing fatload ide 0:2 0x02000000 /boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:2 for fatload **
    ===> Executing ext4load ide 0:2 0x02000000 /boot/boot.scr
    ** Bad partition 2 **
    ===> Executing fatload ide 0:2 0x02000000 /boot/boot.scr
    Error No HD connection 
    ** Can't read from device 0 **
    
    ** Unable to use ide 0:2 for fatload **
    egiga0 no link
    Using egiga0 device
    TFTP from server 192.168.15.100; our IP address is 192.168.15.223
    Filename 'boot.scr'.
    Load address: 0x2000000
    Loading: T T 
    
    #11859

    Eun
    Participant

    Nevermind, I grilled my cubox by inserting the wrong power cord…

    #11860

    Warped Rudi
    Keymaster

    S***t. You’re not the first person with that problem. Even though I *think* there is some kind of soldered-in fuse, I guess it won’t have been able to protect the device.

    Just for completeness:

    I wonder if there should be a boot partition on the sdcard? Because for me there is none.

    No. The ‘SR1’ u-boot supports “ext4load”. Thus we can stuff everything in one partition. In theory:
    ===> Executing ext4load mmc 0:1 0x02000000 /boot/boot.scr should have succeeded. Interestingly, it reports “** File not found”. This is different from the “** Bad partition” messages that we get when the other devices/partitions are probed.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.